Obstacle avoidance problem

currently I’m building a quadrocopter which has a SF11 -C lidar rangefinder. (Pixhawk cube)
My plan is to use this sensor for obstacle avoidance. I followed these instructions:
and mounted the lidar sensor in the font. If I put the copter in stabilize, it corrects itself
as it should. However, if I hold an obstacle in front of the sensor the copter does nothing special
(It is stabilizing as it is in stabilize mode but in doesn’t try to slow down, fly away or avoid the
obstacle in any way). Btw. I also get a lot of annoying pop-up windows if the pixhawk is connected to the computer, which show an image of the copter and the Obstacle which it is seeing. Those windows pop-up approximately every 3 seconds and are pretty annoying, as I can’t do anything whilst a new Window is constantly getting opened. I would really appreciate it, if someone know a solution to either get the object avoidance working (maybe I just have to tell him what to do if an obstacle comes to close) or to get rid of those pop-up Windows.
Greetings Mathis

@Mathis These windows are the ‘‘radar’’ screen when you use an rangefinder in an orientation different than lookinfg down (25), If you upgrade Mission Planner these are now optionnal and you need to CRTL-F to activite them. http://ardupilot.org/dev/docs/code-overview-object-avoidance.html#reporting-to-the-ground-station

Have you setted a switch on the radio (ch7 or 8) to activate the avoidance - option 40 ?

thanks for the quick reply. Unfotunately after I have changed the ch_7 option to objekt aboidance and flipped the switch, the objekt avoidance isn’t working etiher. Btw, I am using the newest version of the mission planer (1.3.53) but I get those pop-up windows anyway.
Greetings Mathis

I also found a option in the parameter list in the internet, which is called avoid behavior. However I can’t find that in the parameter list of the pixhawk. I could imagine that this is the missing part (as far as I know I haven’t told him what to do in case of an sensed obstacle).
Greetings Mathis

Have you a recent firmware on the pixhawk?

Just read, that I might need to include a library for the objekt avoidance to work.(AP_Proximity, AC_Avoidance) Is that true or is it possible without them? Yes it’s the latest firmware.

They are included in latest firmware but you need to enable them with mission planner
Using these paramameters:

I’ve already set these parrameters to 7/ 4. However, I can’t find Avoid_behave or distance_sensor.

I would test with proximity only == 2 UseProximitySensor
I think behave is not implemented

Unfortunately, that isn’t working either. What exactly is proximity only meant to do?

It mean that it is feeding only with rangefinder not the fence,
what distance have you setted?

Next time I will ask for the complete list so we wont go step by step :wink:

Which distance do you mean?
Avoid_Parameter.param (13.5 KB)

I just tried setting it up again and somehow it works now :). Anyway thanks for you support and the time you spend helping me. The only thing that isn’t working now is the real time radar… I just can’t open the window…
Greetings Mathis
Avoid_Working.param (13.3 KB)