Servers by jDrones

Obstacle avoidance not working properly

hello, I have problems with obstacle avoidance with my rover Omnibus F4 ardurover 4.0 TF luna lidar. the reading of the lidar is accurate but does not seem to avoid obstacles. I followed the wiki setting the parameters as indicated. in particular I don’t find this in the full param list:

RNGFND_TRIGGR_CM

Why can’t I find it?

https://ardupilot.org/rover/docs/rover-object-avoidance.html?highlight=object

Perhaps because you are looking at an Archived Wiki entry?

Dave,
so it is no longer useful? what has been replaced? Thank you

Bendy Ruler with the OA parameters I think. I don’t have a sensor on my Rover but have been following the dialog.
https://ardupilot.org/copter/docs/common-oa-bendyruler.html

I would be interested to know how this works out with such a low cost sensor.

2 Likes

The sensor works fine but the rover does not stop in front of obstacles. Here I put some bin logs of both ardurover 4.0 and 4.1 beta

You need to enable fences to use bendyruler.
PARM, 113769478, FENCE_ENABLE, 0 This one should be set to 1.

In Mission Planner: Config->GeoFence-> Enable checked.

@hendjosh sorry I do not think that is true for BendyRuler. BendyRuler works just fine with fences off and a proximity source enabled. Dijkstra’s does however only work on fences and needs it enabled.

@rishabsingh3003
Doh! That is what I get for never using proxy sensors yet and always having BR+Djikstras on.

Thanks for the reply! Actually I haven’t tested the bendyruler well yet (it’s raining outside) but the simple stop in indoor acro mode would be enough, instead my rover seems to have a hesitation, but then if I keep the command all the way forward it resumes the movement and hits the obstacle. my logs are made indoors (obviously without gps) to test the simple stop.

Servers by jDrones