Servers by jDrones

Not working single copter

I have installed mission planner, plugged my pixhawk in loaded the latest copter firmware,set frame class to 8.
And it’s still not working, yaw doesn’t work, and pitch and roll dont work, see the video linked below for my problem.

Note: these are not flight fins these are only here to show the servo numbers, I have them all plugged into main output 1,2,3,4 and my main motor on 5

Everything seems to work for your servos (assuming you have one plugged in main motor 5).
The problem is that your radio is not set properly. When you thrust up, it’s doing the yaw movement. By default ardupilot considere the channel 3 of you transmitter as thrust, see the doc on the basic RC channels here to set your radio : https://ardupilot.org/copter/docs/common-rcmap.html

You can either change your radio to send thrust on channnel 3 or tell ardupilot to considere channel 4 as thrust. Of course do this for every channel and check that Pitch/yaw/roll/thrust are all at the right place.

You can see what ardupilot is recieving as pitch/roll/yaw/thrust in “radio calibration”.

Just tried it and it didn’t work unfortunately, I’m trying to do a ducted fan rocket but I dont know why it’s not working to get it working , its literally just a single copter with a extended shell

Setting the radio channel didn’t work ?
Or did it work, but the servos still do the same thing ?

Can you show the radio callibration tab moving with your controller. And, if you changed the radio setup, could you, once again, show the servos moving with the controller

I tried what you said it didn’t work at all, I’m not sure if it’s the flight controller, which is a pixhawk fmu3, and I am using a 8 channel radio from radiolink

I dont think it worked, ibswapped the throttle and yaw around and its didn’t work, when On default setting ls the motor throttkes up and all that

Is the Radio Configured for AETR? That’s why @hubble14567 was asking to see the radio calibration tab.

No how do I find the AETR and what shall I set it too thanks

Basicaly your radio sticks IRL should be like this :

and you should see the coresponding value move here in mission planner (arming is not requiered) :

Follow this doc if there is any descrepency : https://ardupilot.org/copter/docs/common-rcmap.html

It should work, if not, please send a new video of the servos’ movement like before (with the numbering). I’m pretty sure it will work, but you may not recognize the movement when armed since it’s not exactly the same as the documentation that describes the non-armed movement.

Oh yeah my controller does all of that

Servers by jDrones