Not Working in auto mode

Hey can someone help me as I have made a boat and am using ardupilot mission planner1.3.75.1 arduRover V4.1.0 manually it is working but I want it to run under automode, I am unable to give comand from ardupilot my motors are not running when I selected “Set motor spin arm” it. " Error param MOT_SPIN missing … What should I do how to run my motors in auto mode …

Please read the documentation:

“MOT_SPIN_ARM” is an arducopter parameter. It would be a bad idea to let the motors on a rover or boat spin after arming. The vehicle would just drive away…

1 Like

We want mission planner to command motor to automatically to waypoints , In our case, everything works except motor don’t propel to the waypoint/ mission. We can drive our boat via controller but not via mission planner … can you explain

There is no shortcut to a working ardupilot vehicle, I am afraid. Between driving around in manual mode and having the vehicle follow an auto mission are many configuration and tuning steps. If you follow the steps in the documentation, you should get there. If there are any problems on the way, please feel free to ask.

Thank you for your reply but still I didn’t got my answer we did everything read the documentation and all but we need to operate the boat by using mission planer without using control, there is a option to operate the boat in auto pilot by giving waypoints, but we are unable to do that and what option or setting I couldn’t find in mission planner, if you suggest me step by step how to enable the auto mode for boat which has two motors only …

You did tune steering and throttle in acro mode? Your boat does work in acro mode?

It didn’t worked we tried all modes

Please post a parameter file.

I can give you my team viewer can you do from there am at UAE time

Just save your parameters to a file and upload them here and I have a look. It is done in the “full parameter list” view in Missionplanner.
I can not use teamviewer, their license checking goes mad on my PC.

09102021_USV.param (14.4 KB)

Can you check the attached file and help me out

This parameter file is at default settings. Your boat will not work that way. You said you read the documentation and followed the instructions given there, but this parameter file has no configuration or tuning done at all. Did you upload the wrong file by accident?


Give me you number I will call you…

Sorry, not going to happen. I will answer questions on this forum, where I can write when I find the time.

Just step thru the configuration and tuning wiki’s sequentially like everybody else does. It’s not difficult if followed in the manner it’s written.