Not Using external Compass

I see that my Pixhawk uses internal Compass instead of the one external in the ublox.
I see no way to force it to use external (even tough there is a setting, it seems only valid for APM)
My internal Compass has too high offsets and I really would prefer using the external and maybe the internal as backup…

I’m not %100 sure but I think the pix will detect a external when connected and default to use that one.