Not stable VTOL X8 + 1 when decreasing

Built VOL 3 meters and weighing 11 kg. separate power supply, okto _quadr X 8 circuit, made the first successful flight, but on the descent it was very much rocked, I was afraid to break it. Another problem is that when RTL was turned on, he tried to fly away, when viewing the log, I found that there was a compass error in YAV. the wind was 5-11 m/sec. the actual current is exactly 2 times more, one of the two batteries on take-off goes past the current sensor.
if it’s not difficult, look at the log, what is my mistake
problem - YouTube

That log is not making much sense to me, it doesnt seem to match you video or description at all.
Altitude changes are practically nonexistant and there’s only about 20 seconds for quad motors operating.

RCout11 seems to be configured as both Motor7 and Tail Tilt Servo - so that could be an issue. I’m not sure how that even happens.

Maybe try the VTOL quick tune first up and move on to QAutotune.

please excuse me, I attached the wrong log, now I’ve fixed it