Not getting servo output in MP for VTOL (QuadPlane) vertical motors

I have a quadplane design, and I want the Pixhawk (Cube Orange) pins to be as follows:
Main 1,2: Ailerons
Main 3: Elevator
Main 4: Throttle (FW)
Main 5, 6: Rudders
Aux 1,2,3,4: VTOL Motors

I have set the Servo output parameters accordingly, but I don’t see a value on Motors 1,2,3,4 on this screen:

I haven’t tried arming the system yet.
I am using ArduPlane V4.2.3. Q_ENABLE is set to 1. Any other parameters that I am required to change to see the servo output here?

have you installed Q_FRAME_CLASS , Q_FRAME_TYPE ?

Hi Alexander.
Yes. Both of these parameters are set to 1 (for Quad, and X config).

click functions in the drop-down menu, select motor 5-8 for the position you need, for example 5-8

Do you mean this?

The PWM position still doesn’t change.

check this BRD_SAFETY ENABLE 0

1 Like

I just tried that, and was coming here to post this as the solution, until I saw your reply having the same suggestion.
This solved the problem.
Thanks a lot for your inputs Alexander!