Not directly go to waypoint, but not fly away

Hi All,

I tried to fly a mission. But the first I notice, on auto take off, the plane turn right. After that it’s not directly fly to way point, but taking a strange route until got near to way point, then going around and around until getting near to the way point.
The wondering repeated to every way point. The issue is not fly away, but the mission result become unusable.

So… no one ever experience this??

The dataflash log did not contain any flight. Only about 3 minutes on the ground.
The dataflashlog shows default parameters, suggesting you did not do any tuning.
The telemetry log show that roll and pitch does not follow the autopilot commands very well, looking like it is not tuned.

If you haven’t tried it, I highly recommend the new Roll/Pitch Autotune function: … -autotune/
(Available in APM:Plane 3.0.2, you have to update from 3.0.1 to use it.)

Safe landings,

I did autotune last Friday, and it helps a lot. Anyway the response result on autotune seems quite mild, even on 7.

Is the autotune know when to stop adding value on PID? if it is can I always fly on autotune mode, so it will become more precise everyday?