Not able to select Acro or Flip flight mode APM , Ver 3.2.1 or 3.1.5

Thanks in advance
I have 2 different APM boards, one is a APM3.1,Tricopter and other is APM2.6 Quad, APM3.1 is running firmware Ver 3.1.5 , APM2.6 is running Ver 3.2.1, using a Flysky TH-9X transmitter. Here is the confusing part, all this was working correctly last time I flew a few weeks ago, I am using Mission Planner Ver1.3.3.7 this is set up correctly. I was flying the APM2.6 Ver 3.2.1 in a quad and flying well then I noticed when I would activate switch for FLIP, there was no FLIP? Back home to Mission Planner connected OK but when I go to flight modes FLIP is in the drop down list but if I select it the text will turn black like it does not support that mode? The same thing is happening if I select ACRO from the drop down menu, if selected the text will turn black, other drop down flight modes seem to select OK?
The same thing is happening with my APM3.1 on a Tri copter firmware Ver 3.1.5 very same thing as explained above with the 2.6 board?
I even tried a newer version of Mission Planner on a different computer and the same thing happens there?
Anyone ever had this happen, I have tried reinstalling firmware but outcome is the same?
Any Help is appreciated

Ok rookie mistake, I guess the text blacking out has always been there and I never noticed it before?
I have learned that anytime you select a flight mode (such as ACRO) that does not support Simple or Super Simple the text will be blacked out.
Thanks anyhow