NOOB question - unable to config CRSF with AP for differential thrust

Hi guys, I have been working on this for a couple weeks. Ive made progress, but having trouble setting up the Matek F405 wing WSE for a differential thrust flying wing. Would I be helpful to post the config dump file (.param) . I have tried attaching here.

Here is the link to RCGroups where I have some pictures of the board and radio settings. RC Groups - View Single Post - Matek F405-WING Flight Controller // iNav & ArduPlane


  1. Is my Crossfire setup correct?
  2. Im not getting any kind of correct output from flight controller when servo outputs are configured, what am I doing wrong/missing?
  3. Any other constructive suggestions?

Thanks guys


diff thrust setup.param (19.1 KB)

One of the pictures on rcgroups shows aileron mixing on the transmitter. You do not want this. All the mixing is done by Ardupilot. Just set up the transmitter for standard aileron/elevator/throttle/rudder.

Not sure if it matters (I don’t have Crossfire), but your model setup is configured for channels 1-16, but your “nano rx” is set for 8-ch mode.

When you wiggle the sticks are you seeing movement on the “radio calibration” tab in Mission Planner? If so then the crossfire link to the flight controller is good.

How are you testing for “correct output” of the flight controller? Have you calibrated your accelerometers and compass?

It looks like you have the receiver on UART1 as per the Matek documentation. You might want to power it via a 4v5 pin so that you can get power to the receiver when plugged in via USB. You can do this by removing the power pin from the servo connector and putting it into its own connector. Just lift the little plastic tab carefully with a razor knife and it’ll slide right out.

You could add 256 to RC_OPTIONS to enable passthrough for CRSF telemetry. This would let you use the yappu telemetry script on an OpenTX radio.

I notice you’ve got RUDD_DT_GAIN set to 50, that might need tuning.

Thanks chris.

Let me go through and make sure all the mixing is off on the transmitter. Also, I will check the 16 vs 8 channel difference between the TX and rx.

I also need to go back in and recheck radio calibration. All of the sticks move, so I believe it’s getting signal. At the moment with the current setup, I just have one switch setup for toggling modes, I can always set up more later.

Yes, the GPS I am using does have a compass. I have calibrated accelerometers as well as the compass. I can go back in and double check all those as well. Let me knock out a few of these small items and see if I can’t get just simple elevon function working. Right now whenever I wiggle the throttle up and down, I can see and hear servo movement. Is that because of how I currently have everything set?

Another question I thought of, I believe the ESC are running BLHeli fw, does this make any difference? I tested both independently before hooking them up and know that they do work. Also, another thing I just thought of is that when I go in to do ESC calibration, I get some error. When I go in this evening I’ll try to get a screenshot of that so we can troubleshoot.

Yeah I saw RUDD gain was set high. I was honestly just trying to play around with settings just to see if I can make something work. I’ll get it changed before I actually take it up.

I like the idea of independently powering the receiver via USB to be able to play around with things. I’ll work on that this evening. My plan is to definitely download the YAAPU telemetry script. I like the fact that you can do the CRSF as a pass through and still be able to use it. Thank you for that.

If you’re getting servo movement when moving the throttle, your channel mapping is probably wrong. I notice your mixer order is TAER, while Arduplane expects AETR. (As documented at Radio Control Calibration — Copter documentation)

Make sure that the appropriate stick controls the appropriately-labelled input on the “radio calibration” page.

Normally you’d want to make sure that the autopilot-commanded servo corrections are going in the right direction (reversing them if needed) and once that’s working then you’d make sure that the TX-commanded servo movements are going in the right direction (reversing them in the TX if needed).

So I was able to get things communicating.

With the RC_OPTIONS, my current setup is set at “32”. Do I change or add 256 to that number? I didnt see any documentation showing how that works with the YAAPU script, did you have any additional info about this? Also, truthfully I dont know that much about that script other than how it can be used for passthrough telemetry. Do you have a link to documentation for that as well?

appreciate your help Chris

I got the YAAPU script loaded to radio. I get all the little windows of info on the radio, but I will not get telemetry data. hmmm. I was able to get it to come up once, but them after power cycling the radio/battery, it did not come back. Suggestions?

Another thing was that even when the telemetry was up, I never got GPS data or artificial horizon info to work. Does this sound like a setting?

I set RC_OPTIONS to 288 (32 + 256).

Let me know your thoughts.

Here is the param list:
4-17-22 setup.param (19.1 KB)

Did you enable Crossfire in the Yaapu Config Menu on the radio?
Yaapu Crossfire

Thanks dave. I believe so but I’ll double check and go through the documentation to make sure everything is set properly

Happy Easter!