Noli's upload problems with Copter-3.5.2

this is a discussion for Noli’s issues uploading Copter-3.5.2 (and higher) to two Pixhawk boards. This discussion is moved over from Facebook.

Noli, so the first thing is please downgrade to Copter-3.4.6 and see if that works. That will allow us to determine if the flight controller board works at all.

You can install Copter-3.4.6 by open mission planner, go to the install firmware screen, select “Pick previous firmware” and select "AC 3.4.6 … " from the drop-down.

To check if the board works two things should happen:

  1. the board’s LEDs should light up
  2. you should be able to plug in a USB cable, open mission planner’s Flight Data screen, select baud to 115200 and push the “Connect” button on the top right.

Noli, so just to be clear. Today you uploaded 3.4.6 and then connected with mission planner? Can u set set log-disarmed =1 and then dowload a dataflash log and then attach it here? I would like to make sure all the sensors are working.

OK, so the issue is that you can’t get any version of ardupilot running on this board.

What type of PC are you using? If it’s Windows which version of windows is it?

Can you please try to upload using the mission planner? Instructions are here, please follow them carefully.

As a side note, I’ve heard you mention a few times that the other firmware works. That’s fine, i understand.

I run Mission Planner on windows 10 every day on two different PCs. It should work and if it doesn’t, let’s get MichaelO involved to get it working.

I just feel that to get to the bottom of this issue, we need to remove as many variables from our setups as possible.

So can you please try to install the latest mission planner on your PC?

OK, great. So now:

  1. Open MP’s Initial Setup >> Install Firmware screen.
  2. first check the port drop-down and see what’s listed there, then plug in the Pixhawk and check the list again to see what new com port has appeared. Please tell me what that comport name is.
  3. set the baud rate to 115200 (although it’s not important for the upload process)
  4. click on the copter icon (APM:Copter V3.5.4 Quad).
  • it will as “Are you sure…”, select “Yes”
  • it will say “Please unplug the board…” so unplug the board and plug it back in again and press OK
  • it should say "Downloading … " <-- what exactly does it write below the bar on the bottom left?
  • then it should upload and the green bar should move to the right as it load <-- does it do this successfully?
  1. after uploading, if you have a buzzer attached it will play a tune. What tune does it play?


Using another firmware isn’t going to help so let’s please stop discussing other firmware. It doesn’t help get to the solution.

How are you attempting to connect with MP? I get the feeling that you are attempting to connect with the Terminal screen instead of with the Flight Data screen. Please connect from the flight data screen.

You say you get “all the buzzer sounds” but there are 14 different sounds listed on that page. You can’t possibly be getting them all. Perhaps you could make a short video of what you are seeing and hearing?


Please stop repeating yourself and please follow my instructions above.

you can simply drag-and-drop photos here.

So you are saying you can upload Copter-3.5.4 with MP and connect successfully and it works? If “no” then please follow my instructions above and answer the questions I have asked:

  • what exactly does it write below the green bar on the bottom left during the firmware upload?
  • what sounds do you hear after the upload?

Ok, please try to use Mission Planner to upload Copter-3.5.4 ( and connect with Mission Planner as described above. Then please answer the questions I’ve asked.


Please answer the questions I’ve asked:


Disconnect from the Copter BEFORE going into Firmware.

It will not get firmware if you are already connected
Just make sure the port and speed is correct but do not connect.

It says “upload done” in the first picture. That indicates the upload worked. Where did you connect to in the second picture if the upload and booting did not work? A flightcontroller without firmware won’t accept incoming connections.

Even Missionplanner knows it is connected to APM:Copter 3.5.4. It tells you so in the window title. Look at your screenshot again.

It does look like it’s worked. If you go to the Flight Data screen and move the board around does the HUD move?

There also may be some messages in the Flight Data screen’s messages tab (on bottom left).

I was actually asking two questions which amazingly I’m still not getting an answer to. I’ve asked these questions 4 times already:

Answering the first question tells us which firmware exactly the mission planner is uploading. It should quickly flash the words, “Detected a px4-v2” or “Detected a pix4-v2” or “Detected a px4-v4”.

I think uploading a picture of the actual board being used and/or provide a link to where you bought it will tell us what board you actually have.

If mavlink is working then firmware is working too …
pixhawk v2.4.7 only exist on aliexpress … why don’t know what is inside … Could you answer Randy questions and share what do you have in Flight Data screen ? If you can get us a screen of what is in the message box after connecting it will help too

Bottom line for new readers: Noli refuses to answer direct questions from Randy.


It’s a bit rich calling people trying to help childish.It’s you that are being childish in steadfastly refusing to answer Randy’s questions instead preferring to only supply the information that you feel is appropriate.That behaviour is not showing Randy the respect he deserves.

Your screenshot above clearly shows you have connected to a booted flight controller running AC3.5.4 (284349c3).

The questions you are repeatedly refusing to answer are

I’ve read the full facebook thread and got no information from your posts there.I haven’t seen you respond to Randy’s questions except for reposting screenshots of nothing in particular.I haven’t got any information here either,simply that you believe that the Arducopter code is massively flawed.Not why.No evidence at all.Simply a much repeated claim with nothing to back it up.Perhaps if you actually answered the questions Randy has been asking repeatedly you could get some help identifying what the problem is with your flight controller.I’d expect internal photos of the FC and videos of each firmware upload and boot attempt with a full explanation of why it is not working.There is no actual useable information in your thread yet you are posting wherever you can that the Arducopter code is flawed and doesn’t work on Pixhawk 1 FCs.That is against the general evidence.Posting links to folk having GPS problems in unhelpful in the extreme.It may help you to justify your actions but it provides zero useable evidence of a fault with the code.

Now,please kindly answer Randy’s,and other folk’s, questions in an orderly fashion and you may get somewhere.I still have absolutely no clue what behaviour leads you to believe the firmware hasn’t loaded.That little fact seems to have been omitted from the thread.Along with several others.

I’m not saying there isn’t a fault with the code just that this is not the correct way to assertain exactly what it may be.

Not using this Pixhawk1 v2. 4.7 anymore for Ardupilot.

Deleted all the messages to keep people from replying without reading, including 2 FB groups messages, especially the replies were mixed up. 2. 4. 6 and 2.4.7 have problems in Ardupilot but works perfectly in PX4Pro firmwares. But 2.4.8 working in Ardupilot according to FB groups members.

Just confirmed 2.4.8 board woks with AC 3.5.4 according to SOLO brain transplant FB group member.

@tridge can you please add support to Pixhawk1 v2. 4.7 board? AP and AC could not properly identify the board, only PX4 can. See 2nd screenshot below.

Randy, Thanks for your help and time.

I have mission planner on 3 pc and no problems. Firmware runs perfectly on different boards.

Oh, that’s rich! You of all people asking for details and yet you refused to provide any details regarding the problems you allegedly had.

I smell Trool poop…