No yaw response after 3.4.2rc2 upload

I uploaded rc2 to both my hex and quad, the hex flies beautifully but the quad does not respond to yaw input. I have redone all calibration with no results. I reloaded the previous firmware and all was well. I then reloaded 3.4.2 rc2 and back to no yaw control. I was happy to see that uavcan communication was fixed so that my zubax gnss2 works now.
First time posting on the new forum so I hope this is the proper way to post.

Cheers and thanks for continued effort

Thanks for the report. If you have a log file that’d be great.

This is certainly related to the ACRO_Y_EXPO changes. I suspect if you set that to 0.3 it’ll be like it was but it would be good to understand the cause of the problem.

I have included two log files, one with ACRO Y set to .3 and the next at .8. I could not notice any change at all, still no yaw control. I did get out and ran the 1M hex through a couple of batteries and it flies beautifully, rock solid and very predictable.

Thanks, RB

61.BIN (899.3 KB)
62.BIN (787.6 KB)

I’m not sure if you have had a chance to look at my log files but it appears that no one else has come across this issue. It must be something in my parameter set up but I have been through everything I can think of with no luck. Logs look like yaw request comes in but no response on the output side. I’m still struggling with reading log files so any help you could provide would be much appreciated.



Sorry for the slow response.

There’s a couple of parameters that might be related to the problem although I’ve tried changing these in the simulator and the simulated copter still flies ok:
ATC_RATE_FF_ENAB is 0, try setting to 1
ATC_ACCEL_Y_MAX is 0, try setting to 27000

By the way, I can’t see the RC input and output in the logs. Could you set LOG_BITMASK to 176125?

That did the trick Randy. I just finished a yaw axis auto tune and this thing finally flies like I always thought it should, by far the best it has ever flown.

Thanks for the help and helping to develop an incredible system

Randy Bachtell

Thanks for the help. I have attached a short log file of a bench test, if you need a more complete test i will get one tomorrow weather permitting.

60.BIN (403 KB)

Here are two logs, one with acro y set to .3 and one at .8 no noticeable improvement.

61.BIN (899 KB)

62.BIN (788 KB)

Thanks for the help Randy, that seemed to do the trick. The quad flies as it should now. When I get a chance I’m going to do an auto tune to see if I can get it a bit more stable. Thanks again and I wasn’t concerned about a slow response I know you are busy with more than just my small problem.