No throttle output

I can get no throttle output on HeliRSC channel.
HeliRSC mode 1, Heli is armed, motor interlock not engaged,
RC8_in is 70%.

Arducopter 3.7.0-dev



arducopter-20190318.param (19.5 KB)

Hi, welcome to the no throttle club :slight_smile:

do you have a log with channel 8 and servo 8 output in a sequence when you are an increase the throttle in your receiver ?



welcome to the no throttle club

does that mean, this is a common issue ?

Unfortunately I cannot produce a log due to another bug:


But channel 8 goes up from 1000 to 1698us and servo 1 doesn’t do anything.
HeliRSC is on servo 1 on my Matek F405-Wing.


Did you recently upgrade? And if so what version were you on where it worked correctly and what is the version where you saw this problem.

disable pre-arm logging this will help to arm produce a test with log.

@Bill: no, I didn’t upgrade, this is the 1st try.

@imed_limaiem: how do I disable pre-arm logging ?
It seems logging does not work at all on my controller.

@twistedwings you say that you loaded Arducopter 3.7.0-dev. You should not using that version especially if this is your first time setting up a helicopter. Please go into mission planner under initial set up and click on the helicopter. That will install the latest stable release of the firmware.

I compiled the 3.7-dev governor branch, loaded it in my Raptor 716, started the engine and ran it up to full governor engage on the ground. I didn’t actually fly it as I don’t trust 3.7-dev is safe to fly due to too many untested changes that have been thrown in for other things not related to heli. But the throttle works fine. There is no problem in the code with the HeliRSC.

@twistedwings I looked at your param file. depending on when you downloaded that version of master, it appears that the interlock channel is actually rc channel 9. If you look at the param RC9_OPTION you will see it is set to 32 which is the motor interlock. You need to set RC8_OPTION to 32. However again, I strongly urge you to load version 3.6.7. Master is an alpha version of software meaning very little testing has been done to ensure it is suitable for our user base.

I was on a business trip.

@Chris: thank you for evaluating this. With my configuration there is definetly no throttle output.

@Bill: I changed fw to 3.6.7 and it worked indeed (without changing the config).
The reason I choosed 3.7.0-dev are the new serial options for frsky telemetry
which I thought were not 3.6.7 but it seems they are. Frsky S.Port telemetry seems
to work with 3.6.7 too.

Well, in 3.7 there is new RCx_OPTIONS and you have to set it to Motor Interlock, which is very confusing as there is no such thing as “motor interlock” in helicopter terminology.

Yes, the serial options for FrSky telemetry have existed well before 3.6.x