No throttle in Steering mode anymore

A few weeks ago I was messing indoors with sonar sensors and lowered CRUISE_THROTTLE param to 0, and maybe some other params that I dont remember, so that the wheels wouldnt spin when switching to Steering or Auto. I could then hold my hand before one of the sonars and see that the wheels would turn in the right direction.

The other day I was supposed to go out and try some auto missions. Though when switching to steering mode I would not get any throttle out signal. Tried raising the CRUISE_THROTTLE and CRUISE_SPEED but still no signal out.
I have since reloaded the default params, changed firmware to arduplane and then back to ardurover and still no throttle out signal. Or at least not enough to move the vehicle but I can see a little raise in the tuning graph. See attached file, between 987 and 988 I turn on steering mode.
Though if I turn on auto mode I get around 20% throttle. See attached file, between 80 and 81 I turn on auto mode.

What am I missing here? Shouldn’t steering mode give the same throttle signal as in auto mode?
Pretty new to ardurover but I’m fairly certain that I have run the rover in steering mode and that I didnt have to give any throttle just steer away from obstacles with the remote control.

My params:

Full parameters list attached.

Sonar sensors have been removed and

It could be your ESC. 20% throttle may not be enough to get the ESC to start the motor.

Hmm, what channels do you have things setup on? CH1 for setting and CH3 for throttle? I ask because all your other channels are set for no output effectively i.e. their RC_MIN and RC_MAX are the same.

Thanks, Grant.

20% throttle is working fine and is moving the vehicle in auto mode.
The problem is that when switching to steering mode the APM doesn’t output any throttle at all.

Only have a 3 channel radio so
CH1 = steering servo
CH3 = throttle
CH8 = switches between manual and steering mode or manual and auto

Loaded ardurover on my pixhawk today and are getting the same results. Only manual throttle.

Could someone please explain how steering mode works? What happens when you enter steering mode?

Created this issue here for me to solve.

Thanks, Grant.