No throttle from autopilot


Currently I’m converting my skywalker x5 into a Y3 vtol plane. After all the wiring and soldering done, today I was configuring the parameters and other configurations and calibrations with mission planner. After adjusting, calibrating my radio control with the flight controller, (Turnigy 9X), I wanted to calibrate my esc next (Hobbywing XRotor 40A OPTO). But after I tried to calibrate with Q_ESC_CAL parameter (both 1 and 2) there’s no respond from autopilot. All 3 esc however did have a beeping and it indicate they indeed powered up. Elevons and tilt servos however has no problem. And my radio control is calibrated just fine with my FC. I can see the input changing in mission planner when i moving my sticks.

Then I tried connecting all my 3 esc directly onto my receiver and I can calibrate them manually with no problem. Throttle is working and motor is spinning.

After that I reconnected all my esc onto the flight controller and tested either its working but unfortunately the problem still happen. I tried changing the servo rail placement for all my connections and still no luck.

Here I attached my parameter and I really hope if anybody can help and see if I messed up anything.

Thank you.

x5 vtol.param (19.8 KB)

When you do the arming step, check the servo output page on Mission Planner and check that you’re getting outputs on those channels for the motors.

In Qstabilize mode, throttle stuck at 1100 min no response, all 3 motor have 0 output.
In Manual mode, throttle signal has response, but all 3 motor have 0 output as well.

My RC3_MIN is 1046 and RC3_MAX is 1879, but in servo output page it show 1100 for min.

Confirm you are arming the system before attempting all of this?

Sorry for late reply. Yes I armed my plane and still no output.

Here my parameter settings for all my SERVOn_FUNCTION:

S1:78 elevon right
S2:77 elevon left
S3: 70 throttle (default)
S4: 0
S5: 33 Motor 1
S6: 34 Motor 2
S7: 0
S8: 36 Motor 4
S9: 0
S10: 0
S11: 76 Tilt motor front right
S12: 75 Tilt motor front left
S13: 0
S14: 0

You have Q_M_PWM_MAX,0
I would set these to 1000 and 2000 µs and use them to calibrate the ESCs again
and the trim values of the motor outputs to 1000.


1 Like

Thank you very very much @Rolf for that! Esc successfully calibrated after I changed the value of those 2 parameters. So to trim the motor output, I need to trim it on Servo Output tab on mandatory hardware setup?

Sorry, I was unclear about TRIM. I would set the SERVOx_TRIM values of the motor outputs (SERVO5_TRIM, SERVO6_TRIM and SERVO8_TRIM) to the value of Q_M_PWM_MIN. As far as I know, this is not relevant for the Q-Modes, but it could be that it is important for the motors in Plane Mode.

Yes, you can also find the parameters and change the values in MissionPlanner e.g. under “Config” “Full Parameter Tree”.


1 Like

Alright I’ve change the trim value. And one more thing, when I armed in QStabilize mode, the motors are automatically running even though I haven’t move my throttle stick. Is that normal in Qstabilize mode?

This is normal and the value is set with Q_M_PWM_MIN. It will be best if you study the wiki: QuadPlane Parameter setup — Plane documentation

Alright thank you very much for your help!

1 Like