No such mode - Error message

Hello, just upgrade my quad to 4.1.0 and re-calibrated compass etc. so all fresh and tidy.
However when I try to select Follow mode as a Flight Mode, I get the “da daaa” tone and a “No such Mode” message on the GCS.
Loiter, and Guided work just fine and auto waypoints etc all work as per normal.
I am using a USB BU-353S4 GNSS module on the GCS, and have 10 sats as a general rule.

Is there a change I need to update with 4.1.0 or something fundamental happened. I tried several other flight modes to see if it was just Follow and most work, and then there are some that don’t?..
I re-did my RC Calibration as well, just to be sure, and same result.
Any help appreciated please.

If the flight controller you are using only has 1MB flash, some features (like follow mode) might be disabled.

So without knowing which FC you use, it is hard to tell if that is the case.

Hi there, its a regular Pixhawk 2.4.8 with 8gb SD card.

I had follow-me mode as a select-able Flight Mode prior to this firmware upgrade, but since this, it has become a “No such mode”…