No standard plane in QGroundControl?

Hello! I’ve been flying successfully with QGroundControl for months but in the last 2 weeks I haven’t been able to choose a standard T-tail airplane in the airframe menu. The choices are either multicopters, V or A tails, or other types of aircraft. I have a traditional aileron, elevator, throttle, elevator airplane design. I’ve tried un-installing and re-installing QGroundControl, both the current and earlier versions, and tried a different, and brand new Pixhawk 2.4.8 autopilot, without luck. I’ve tried using 2 different USB cables at different times between my Windows PC and the autopilot, as well as 2 different sets of radio links. No matter what, when I go to set up the airframe there is no traditional QGroundControl graphical interface with pictures of different airframe choices. I’m only seeing written lines of words giving me choices that do not include a standard plane. I’m not sure what to try next! Any ideas would be appreciated! (Most frustrating is that everything was working fine before!) Thank you!

Looks like you have ArduCopter firmware flashed onto the board. If you want ArduPlane you needs to flash that on the board.

Thanks you! I think I tracked the problem down to 2 bad USB cables. I tried the first one, thought it might be bad, and then went and got a second one. Thank goodness my son uses Monster USB cables. Neither of mine were good, but his worked fine. Now I should be able to flash the board with ArduPlane. Thanks again.

Well, I was wrong. I thought it was solved. But now, even with everything else apparently working, there is now no airframe section to choose at all. It’s just not on the setup screen at all. Here’s what I’m seeing (screenshot attached…) Thanks again!

There is no such thing for ArduPlane.

Thanks, Don. That pointed me in the right direction. After 2 bad USB cables (which I didn’t recognize as being the problem) combined with 2 bad cables for 2 different telemetry radios, I was mystified. I had also been using PX4 but it was changed by a person that was helping me (a lot!) to Ardupilot, which I hadn’t noticed. Definitely my fault, corrected now. With a good high-end USB cable I was back in business and re-flashed the firmware back to PX4 (now showing correctly in the upper right hand corner of the screen.) You gave me the tip that took me to the solution. Thank you.

Yeah, flashing can be flaky. Best results with:

  • You need good USB cable
  • Needs to be directly connected to compuler not through a hub
  • Not from a VM