No soaring parameters in Mission planner

Hi guys

I’m running arduplane 4.0.5 on an pixhawk, but I cannot find the soar parameters in the full parameter tree/ or list. How can that be?

Kind regards Patrick

Which Pixhawk and what version of 4.0.5"? As in this screenshot the line that says Pixhawk1-1M and a bunch of numbers/letters. I’m guessing fmuv2.


And you are looking for it here?

1 Like

Thanks for the amazing quick answer.
I’m running Mission Planner 1.3.70.
I’m connected via Mavlink, I also tried to set the parameter with Qgroundcontrol and I could also not find it there.

Right, so fmuv2 will not have Soar and some other features made available. It’s feature limited to save memory space. But, of you believe your Pixhawk does not suffer from the 1Mb limit as some old ones did then you can Flash to fmuv3 and Soar will be there. What actual pixhawk do you have?

1 Like

I bought this one from Banggood.
If you think it’s not recommended to load the firmware for fmuv3 on this pixhawk, can you recommend me a good one?

That most likely has 2Mb of flash available and can be updated to fmuv3. From the Mission Planner Install Firmware screen select the “force bootloader” option. Answer yes to the next dialog box. Then select the Copter 4.0.3 Official button and make the selections in the attached the “update firmware”. You will get an error if the board has insufficient flash. If this works after this point you can update as usual.