No signal on servo rail xxxxx solved xxxx

I have the same set up on PH1 without problem. I get only signal/power on servo rail Output 1 …nothing on 2,3 etc…
I run MP 1.3.39 with plane 3.7.1 on Fx 61 with elevon mixing.

  • TX is 9XR with Ezuhf chanel 1 => Rud, chanel 2 => ele . Chanel 3 => thro
    config MP
    elevon output 3
    I get signal on radio configuration on MP , sensors are moving fine on pc
    same on failsafe radio 1, 2. 3 you can see cursor moving on pc

the PX 2 is powered as followed
Ubec (Turnigy 5A) of 5.24 V on aux out 1 (I also tried to power with usb, ubec and power module that I have from ph1not brick)

indeed I tried different servo, different ubec…when I swap servo to output 1 works on 2 not…vise et versa…

I flashed again the PX2, bind again the ezuhf …nothing I get power on output 2, 3 because I see a little bzzz on servo when I conect them but defintely no signal…(Ialso get power on all output of 5.3V measuring with Amperemetre)

I’m running out of ideas ? I upload couple of photos

PS : I also tried to remove elevon mixing and change to my skywalker set up set up with rud, ele, ail …same issues no signal on output 2.3,4 only signal on output 1

Have you tried to load previous versions of arduplane, or tried ArduCopter firmware?
Just want to find out whether it is software or hardware issue.


yes I uploaded plane 3.7.1 & 3.8.0 Beta 0 and same issues… I will tonight try different BEC and try Rover or Copter firmware… I will update status…

I felt the cube was moving a little touching it… desassemble it and screwed back on strong …magically it worked…