No servo signal output from Pixhawk

Hello all, I am not able to get the Pixhawk to output a servo signal to control either my servos or my speed control.

Here s my setup: Pixhawk loaded with the latest Plane firmware (3.2 i think). I have 2 elevon servos and a speed control with BEC connected to outputs 1, 2, and 3 respectively. When I connect the speed control, the servos shutter as they receive power and I have also tried powering them straight from a battery connected to channel 7 as well so power on the output buss is not the issue (as others have had).

The pixhawk boots, gets 3d fix and calibrates fine including the flight radio (spectrum satellite receiver direct to pixhawk). Arming is also not an issue, as the button works properly and the autopilot responds to the throttle down - rudder right and mission planner arming prompts.

When looking at the mission planner status fields, I can see the channel output values changing appropriately to control inputs and all the mixing I have set up. However there is no signal getting out to the servos. They freewheel even thought they have power and the speed control does not initialize due to not receiving a signal. The servos and speed control work fine when attached to the spectrum receiver alone.

The servos worked just once when I was first setting up the hardware, but I powered down because the software elevon mixing wasn’t working correctly. When I rebooted 10 minutes later nothing worked anymore (as described above).

Is there some sort of software inhibit field that I’m missing? I have read about issues with bad solder joints on the connector which I haven’t looked at yet, but I have no signal from any of the outputs and they all did work once. Thank you in advance for any insight you can provide.

How is your RCMAP_ setup for PITCH, ROLL, THROTTLE, and YAW?
Also, I would not rely on a Spektrum Satellite Remote for use with an aircraft. The Remote does not have the range that a full up Receiver with the Remote will have. I would consider using a PPM encoder and a full up receiver with the Remote.

TCIII, Thanks for the info about the reciever. I am still waiting for a PPM converter from 3DR (and an airspeed sensor). I didn’t think I would use it since the satellite is working well, but now I will be sure to when it arrives.

The RCMAP settings are set to the defaults (roll = 1, pitch = 2, etc). I checked out the schematic too, the output driver looks pretty robust and it is permanently enabled so unless the chip blew completely (doubtful with how I have been working with it) it is probably a software issue somewhere.

When using a Spektrum Satellite Remote on my Pixhawk equipped ArduRover I had to set the RCMAP_X as follows:
YAW, 4


It is definitely something software related. I reflashed the Pixhawk to Copter and then back to Plane and I had outputs again. I got most of my configuration loaded back up but I couldn’t calibrate the gyros. Somewhere along the way I lost the servos again (and got them back, and lost them) but It doesn’t seem to be a specific setting that I can determine yet. I changed some settings and lost the servos, then I changed the settings back but didn’t get the servos back.

I will mess with it a bit more when I get some time. Hopefully I can determine which setting or combination is causing the issue.

I’m about ready to give up on this Pixhawk. I spent hours going through all the settings after a fresh reflash and had the entire thing working great, including FBWA stabilization when I moved the airframe. The only thing not working was reading the voltage and current from the power brick (it worked before but I didn’t care since the servos and prop were working). I powered down since it was too late at night to fly the maiden.

Today after work I pick it up to give a quick demo to my wife before I went to fly and SUPRISE! no outputs again. The IO amber B/E LED is lit which means “Initialization error, check your RC config options in your parameters”. I HAVE NOT CHANGED ANY PARAMETERS FROM WHEN THINGS WERE WORKING!!! Strangely the voltage and current measurement is working fine now too. How can things change when it is left un-powered overnight? I rebooted many times while I was setting it up and no issues occurred, but today nothing. Should I just hope for better luck tomorrow? Is it only possible to fly when the pixhawk feels like cooperating?

I would like to attach my configuration file, but the forum doesn’t allow it. Any Ideas?