Servers by jDrones

No Servo Output-Radio Link Mini Pix

I am new to Ardupilot and am having a devil of a time getting it to work with a Radio Link Mini Pix.
As shown in the picture below, I only get servo output on channel 3, and it does not respond to Radio Input. None of the Output bars respond to radio input. All of the radio input bars respond to my FlySki FS-i6. My scope shows Mini Pix ESC 3 outputing a 50Hz 1Ms. pulse.

Here’s what I’ve done for this test:
Downloaded mini-pix ardurover.apj V3.5.2 stable
Flashed with Mission Planner (V1.3.68)
Reset parameters to default
Set ARMING_CHECK to 0 so I could arm
Mode to ACRO

Flight Data Screen shows: BAD AHRS/(SAFE)
No output on mini-pix ESC 1,2 regardless of radio input.
50 Hz. 1Ms pulse on ESC 3 regardless of radio input

I hope someone can tell me what I’m doing wrong.

Here’s the parameter file(I hope).
miniPix.param (12.6 KB)

Thanks,
Dave

your in safe mode, press you safety switch or turn it off with BRD_SAFTEYENABLE

http://ardupilot.org/copter/docs/common-safety-switch-pixhawk.html

Peter,

Thanks for your input. I disabled BRD_SAFETEYENABLE, but that didn’t change anything I was seeing. I checked the parameter tree to make sure that it was disabled.

Dave

did you switch it off and on again?

Yeh, I had to reboot the mini and now I’m getting servo response on channel 1 and 3 as expected. But it’s still 50Hz PWM. I’ve got to double check the motor configuration.

Thanks,
Dave

OK, now we’re cooking. What I didn’t realize was that I had to re-boot the mini after making parameter changes. ESC output is now at 16KHz which I need for my brushed motors.

Thanks for getting me pointed in the right direction.
Dave

Servers by jDrones