No servo output after install

Just installed 4.0.9 on pixracer.
No changes to configuration.
On servo output page all servos shows 0 (position), only throttle is set to normal value (1100).
What am I missing?

Hard to say so here’s some ideas:

Safety switch - BRD_SAFETYENABLE

1 Like

Looks like BRD_SAFETYENABLE = 0 solved problem but question is why after clean install I see proper output on F405-Wing but on pixracer I need to change flag.
I believe servo outputs should always be active.

Like below (from F405-Wing)

But i case of pixracer (just after flash) I see this

I’d guess it has to do with the configuration for one board to the other. My F405-wing didn’t have a safety switch, but the PixRacer kit I ordered did come with one. To me it seems each board defaults slightly differently when it comes to details like that. You know, keeps us on our toes.

I agree, but it’s illogical to have motor output enabled but no servos.

All in all thanks for help.

1 Like

It just occurred to me that the PixRacer I’m using is going into a quad build, not a plane. It is defaulting all the motor outputs to 0 PWM until the safety switch is pressed. So that means the ESCs are all beeping till the switch is activated. I’ll probably end up disabling the safety switch just because the beeping every time I change the battery is driving me crazy.