No response yet on getting Mission Planner SITL to work

I’m anxious to run some of the simulations that Andrew Tridgell has run in his very educational videos.

Unfortunately - perhaps due to my ineptitude, I still can’t get the SITL simulator to work in Mission Planner. I’m guessing it’s some step I’m missing rather than a bug in Mission Planner.

So far, the available documentation hasn’t helped. And from the responses I’ve seen from my previous posts, I’m not the only one having difficulty.

I have a fresh installation of Mission Planner running on Windows-10 - with the beta updates applied.

A simple set of steps on how to start and run a “hello world” level of simulation ought to get me started - enough so that I can confirm is me rather than a bug in the software that’s causing the difficulty.

I don’t know who monitors this forum - or how to get directly back to anyone responsible for documentation or trouble shooting with Mission Planner. But some assistance in that regard would be greatly appreciated.

1 Like

Go to the simulation tab on the top. Select the vehicle you want to simulate and click on it.Select if you want to run master or stable. That is all.
You must be admin on your machine


  • How to get out of the SITL session?
  • Which parameters does SITL use or can parameters of an existing flyer be used?

Andras -

Thank you for helping out. Yes - that’s exactly how it’s supposed to work. I even tried running it as an Administrator - no help.

When the simulator starts, the voltage displays in red - as if it’s below arming. It’s 12.9 volts. I increased the sim voltage in the parameters - up to 25 volts - it’s still in red.

I go ahead and load a mission - one I’ve used in “real” life. I switch to Alt-Hold mode, arm the copter, and do a start-mission. The results is error messages - one in the HUD “Mode change to AUTO failed: initialisation failed” , and one in a dialog box “The Command failed to execute MISSION_START.”

I’ve included screen shots of all of these. I should have included them in my initial post. I did include them a week or two ago when I first reported this problem.

I’d welcome any suggestions. I wouldn’t be surprised if I’m just doing some bonehead mistake. The only thing I can think of that’s different from what I’m doing from some of Andrew’s videos is that I’m loading an existing mission, instead of creating one within the simulator.

Thank you for your kind assistance!

First of all update to latest beta, and use stable (4.1) copter with start SITL

Does it run a mission that you have planned in the Simulator? If all else fails Reset to default from the Full parameter list. A mission will run in the Simulator with defaults w/o changing/configuring/calibrating anything.

Good question Dave - I hadn’t tried it. I just did - and sadly, I get the same results.