No response to throttle seconds before crash

Hi all. I have problem with my 700 class quad. Today my flight ended with crash. I was surpised since battery were fully loaded but after short flight (guess 5 minutes) copter started slowly descending in stab mode. I started pushing the throttle in oposite to get it back to safe hight but it didn’t respond at all. Then hit the ground. Fortunately nothing was damaged since velocity of descending was not as high. Anyway I’m confused what could be wrong. Could somebody please look at log from the flight and tell me, what was my mistake?
Here is the graph of RC-outs of mottors and throttle input (green line) - one can see my effort just befor the crash - I pushed thottre stick to the limit (green line) butt no response at motor outputs :frowning:

And here is the log-file

And yet another point - I’m using power module from readymaderc and can’t to find out correct value for setting of current sensor. Volts reading is OK but don’t have correct value for BATT_AMP_PERVOLT. Recommended value is 27.27 [Amps/Volt] as it is 90A range: 90/3.3 = 27.2727
But in log file my amps reading is pretty low and unrealistic: highest ampere reading in this flight was 8.6A, which is not possible since the quad weights at least 3kg and there are 4110 motors. Have somebody the same power-module?

Something looks off with your barometer. Plot it and check it out.

Here’s how to tune you’re Amps Per Volt:

  1. Plug in a fresh battery and immediately do a flight for 5 minutes or so

  2. Immediately unplug the battery

  3. Charge the battery and note how many mah’s it took to charge. Let’s say that was 1,500 mah

  4. Download your log and look at maximum CurrTot. Let’s say it was 1,300 mah. This implies that your APM Power monitor is calibrated too low.

  5. Grab your BATT_AMP_PERVOLT setting from Mission Planner. It defaults to 17

  6. Do some math…
    With my example numbers, you’d get
    NEW_AMPS_PER_VOLT = 17 * 1,500 / 1,300 = 19.61

  7. Set the new value in the BATT_AMP_PERVOLT parameter and save to your copter

  8. Fly to check, repeat until you’re happy the new value gives consistent readings

Taken from:


The problem here was you let the battery get below your minimum battery voltage set on MOT_BAT_VOLT_MIN. This voltage where the throttle limit will be reduced to prevent damage to the battery. The throttle limit will not go lower than 20% between hover throttle and max throttle.

Your battery seems to start at 15.6 V so your voltage calibration is also out or you started on a partially flat battery.
You should probably set MOT_BAT_VOLT_MIN to 13.2V or 3.3V per cell.

Based on your motor outputs there is something wrong with your CG or all motors except one are not working very well.

if you set MOT_BAT_CURR_MAX = 0 this is all disabled. i would suggest disabling these functions unless you have a well calibrated voltage and current sensor.

You’re welcome… Here is a spread sheet that will do the math for you…Power Monitor (6.2 KB)

Thanks a lot for hints Leonard and also Oldgazer for math for calibration. Have to play with battery monitormore intensively …
With one motor I have still problems - it doesn’t seems to be failure on it because I checked in more times. Even the CG is not that off. Not quite precise, but the deviation is small.
I can see the motor (nr. 2) is spinning slower when hovering but it doesn’t have impact on leveling - the copter is still level :-o , and that is strange to me. I would expect flip diagonally over axle with two motors spinning correctly but it doesn’t.

Motors 1 and 2 are spinning at different RPM because the aircraft is physically out of balance along the diagonal line segment between the centers of Motors 1 and 2. This imbalance shifts the center of mass away from the physical center of the aircraft. To maintain the aircraft in a level flight attitude the flight controller MUST send Motor 1 a “larger” PWM signal than that being sent to Motor 2.