No Response from board

Just recieved pixhawk device. I’ve connected safety switch and buzzer and now trying to upload firmware.
Installed MP. The drivers looks like installed successfully: the Pixhawk is in the Devices list with “Working” status.

In the MP going to Initial setup, choosing Quad configuration and COM3 port.
Trying to upload firmware. Looks like MP downloads the firmware, and it asks me to replug device and hit OK. After that I’m reciving message - No response from board.

LED Status:
FMU PWR - constant green
FMU B/E - not glowing
IO PWR - constant green
IO B/E - constant orange
IO ACT - flashing blue
SafetySwitch - flashes red

When Pixhawk is connected normal sound is buzzering (accoring to manual).

I’ve also tried to run px4uploader manually, but constant message “xxx not there…” is displayed.

Instead of unplugging the Pixhawk from the USB, try using the FMU reset switch to reset the Pixhawk.

Also did it. Same result.

Also noticed, that the mail LED is not glowing, And in device driver properties COM port speed is 9600 by default wether in MP it is 115200. Tried to play with that, but still same result.