No RC input using Sperctrum Satellite RC Receiver on Pixracer

Hej all,

I have run into an issue with a new Rover Build. I can get the Spectrum Satellite receiver to bind from within QGC, but no RC inputs seem to be detected, neither when trying to callibrate, more anywhere else. If I change the firmware to Arduplane instead (latest 4.0.7) the inputs are immediately recognized. The same goes for PX4. Have also tried with Mission planner. Is this a bug, or have I missed something?

MRO Pixracer
Spectrum Sattelite Receiver SPM9645
Ardupilot Rover 4.0
ORX TX6i DSMX Transmitter


After some more testing I can now confirm that this doesn’t seem to be a 4.0.0 issue. After downgrading to Rover 3.5.2 I still got no RC. Going back to Plane 4.0.7 the RC inputs are normal, going back to Rover 4.0.0 - no RC. Very annoying.Does anyone else see this behavior?

Ok, so upgrading to Rover Development 4.1.0 solved this. Good news! Exciting to be on the cutting edge! Happy it’s a rover, not a plane! Keep up the good work!