No RC input in Mission Planner

I have a FrSky x8r connected from its SBUS port to the RCIN of my Pixhawk mini, but when I connect to the Pixhawk on mission planner, I’m not seeing any RC input in the Radio Calibration screen. The receiver and transmitter are bound and working, and the really strange part is I had all this set up a few months ago. I haven’t changed anything, so I thought it was perhaps a firmware issue, so I upgraded the firmware on the pixhawk as well as downloading the newest version of mission planner. I have tried every suggestion on all similar posts to mine. Is there any way of diagnosing what the issue could be? I only have one receiver and pixhawk. Thanks!

Good day,
check the correct connection on the fc and receiver,
Check also that you have the appropriate firmware on your receiver… a different protocol between RC and receiver cannot make it work properly.

David,

Thanks, I was thinking of both of those issues. I can confirm that the fc and receiver are properly connected. As for the firmware on my receiver, I have never changed it and this exact receiver has worked over SBUS before, so I don’t believe that is the issue. My guess is that there might have been a short at some point and SBUS on my receiver isn’t working. I will just get a new one. Thanks for the help

I don’t know the Pixhawk mini, so I apologize if this is off base. How is your receiver being powered? Some FCs won’t power the RX unless there’s a battery plugged in, and some need the servo rail to be powered by a BEC to supply power to the RX.

I have exactly the same issue:

  • pixhawk 4 mini with arducopter (chibiOS w latest stable version)
  • SBUS to RC IN
  • RC and receiver bound

Strangely, my setup works for PX4 but not for ardupilot.
Also, using PPM instead of SBUS/RC IN also works…so my guess is that somehow ardupilot/pixhawk4 mini/SBUS/RCIN don’t go along well. Can anyone confirm? Or any hint/tipps? Thx!

You may have to set the SERIAL4_OPTIONS depending on what you’re trying to do.

https://ardupilot.org/copter/docs/common-holybro-ph4mini.html#rc-input

thx for the quick reply! So my setting for SBUS is now:

Still: No RC commands/channels visible in QGC…any other advice?

PS1: the channel monitor shows nothing and zero channels are detected
PS2: The same wiring/setup is confirmed to be working under PX4 (so no faulty equipment)
PS3: I also don’t understand the FPORT config. According to your link, SERIAL4_OPTIONS needs be set to “15”, but here is no option “15”.

Those are bit maps options. So 15 (if my early morning math is right) would be all the options: invert Tx and Rx, half duplex And swap.

Some of that is easier to see in Mission Planner. But should still be accessible in QGC.

1 Like