No RC connection to Pixhawk during RTL

Hi,

I had a really strange situation in field with my plane and Pixhawk. I programmed a autopilot mission to Pixhawk, launched the plane and started the programmed mission. So far, so good.

Suddenly after 20min Failsafe appeared in my GCS screen and plane started to come home in RTL mode. Dont know reason. I have set Long Fail Safe = TRUE.

Real fun started after plane began circling around me in RTL mode. I had no RC connection to plane at all. I tried to change flight mode with my RC transmitter but no effect. I switched FBWA mode using GCS (Mission Planner) and after that I tried to control the plane with RC transmitter, but no effect. Plane flied straight forward in FBWA mode … fading away. I quickly changed RTL mode using CGS command.

So what to do !? Plane is flying around me in 50m and it didn’t react at all to my RC transmitter commands. What a heck was this Fails Safe situation. Could someone tell me how this can even be possible.

What happened in the end to my plane? I will tell you the full story after someone please explain me what was this Fail Safe situation.

@Kazme,
Please provide tlogs and/or dataflash logs to help troubleshoot your issue.
Regards,
TCIII GM

Hi TCIII,

I desperately examined my logs and found solution. Fail safe activates, because RC input channels (1-8) changes surprisingly to 0. I confirmed this on status window. RC input channel values should ofcourse be somewhere between 1300 - 1900 all the time. And why those input drop to zero? Reason was, that I have connected external parachute servo directly to my RC receiver (channel 7). Ok, now during the flight this servo starts moving a little and that’s why Pixhawk RC input channels drop to zero. I tested this behaviour on ground.

So i quess it was my own fault… Now I will make another setup so that parachute servo will get power from own UBEC. I tested this on ground it seems to work.

Ok, now the story about last moments of my desperately flight:
Plane was flying in a circle around me in RTL mode and I had no RC connection to plane at all. I realised that I can change speed and altitude of plane via GCS (actions -screen), even I had no RC connection. So I little by little reduced plane speed and altitude, while it was flying around me in RTL mode. Then is set speed to zero. Motor stopper and plane was quietly flying … I was full of adrenaline. I launched my parachute by RC transmitter and that was working, because RC signal goes directly from RC receiver to servo. And… aaaah parachute opened and plane landed beautifully in forest near me,
With shaking hands I run to forest and found my baby in perfect condition. I felt myself as a Apollo 13 pilot :slight_smile:

1 Like

Hi Kazme,

i have read your post to late!

I had a similar prob too! RTL works but no Auto-Mode!
I Postet my log and param-File.
No answer
Some days later i try to find out whats happen… Now i lost my plane…

Hi Alexander,

sorry to hear if you lost your plane. Hopefully you will find it.

Could you describe your situation, what really happened?
So the plane was in AUTO mode, flying near you and you couldn’t do anything with RC transmitter. Was it like that?

Did you make any ‘custom changes’ to your RC receiver, like I did. I connect one extra servo directly to receiver and you should never do anything like that. Servo will now get power from RC receiver and same time it disturbs PPM encoder hardware. External servo must get its power from own BEC as described in tutorials. I didnt …eh…read tutorials enough :slight_smile:

Anyway, I feel that Pixhawk PPM encoder hardware is not working correctly in that situation. In my case all RC input values were set to pure 0. In normal situations RC values are never zero, so Pixhawk PPM encoder went crazy. And after that you have no possibilities anymore to get control to the plane with transmitter.
But you can give commands with GCS (Mission Planner)… if you have telemetry connection.

Hi Kazme,

i dont know whats exactly happen because i cant find the log-file (i have got panic and switched of the power of the laptop after my plane flyes away out of sight).

i had this problem found out bevor on my other post:

viewtopic.php?f=110&t=13429

now i had buy a new FX79 with APM. I will copy the firmware from my FX61 but this plane never crased!
With PixHawk i had problems at the first time…

Hi,
I download your tlog file and I don’t know what is going on there. At least you are not having same problem than me, because your RC channels are working correctly. You had control to your plane with RC transmitter.

One think I noticed. Every time you activated AUTO mode, “Direct to current waypoint” line (orange line in Flight data screen) was not pointing to next waypoint - which was waypoint 1. In RTL mode this very same orange line was pointing all the time correctly your home. That’s way RTL was working correctly. GPS status was 3, so that was perfect.

No .tlog or .log files?

Also, if you have GCS control you could simply have programmed a landing sequence and hit write, then put the plane back into auto mode.

Or am I misunderstanding that Auto was not working?

Also, you can turn off your RC Tx failsafes if it was conintously being activated from the Tx then program the land mission while in RTL, write waypoints, then go to auto and get your plane down safely.

Hi Kazme,

yes! If i switched to AUTO-Mode, the Plane fly away! Last time i lost because out of range and no RTL.
From this, i dont have log-Files (its 0Byte on the Directory because file are corrupted (panic switch off laptop and follow plane))

i thought i can help you with my problem because no other answerd to my post.