No Radio Calibration with ExpressLRS?

Can anyone confirm if ExpressLRS is working with Arducopter 4.1.0 stable? No green bars at all on Radio Cal tab. Have tried two different receivers (Happymodel ES900 and BetaFPV Nano 915MHz). Using parameters of SERIAL7_PROTOCOL = 23 (RCIN), RSSI_TYPE = 3 (Receiver Protocol), RC_OPTIONS = 9 with BRD_ALT-CONFIG = 1 for Matek H743 board with receiver connected to Serial7 = UART6 on this Matek board. Since it has failed both times, I even tried setting parameters (per ExpressLRS site) of SERIAL7_BAUD = 115, and RC_PROTOCOL=9. Running ExpressLRS 1.2.0 on both ELRS transmitter module and BetaFPV Nano 915 Mhz receiver. Receiver is bound to transmitter module with Password Phrase. Transmitter is getting telemetry from receiver. Not able to calibrate transmitter with Mission Planner Tab (no green bars)

It’s not officially supported

Oh, wow, thank you so much! I’ve been banging my head on this for days. ExpressLRS site says you need Ardupilot 4.1.0 or above. So, I’m running 4.1.0 Stable.
Couple questions then please

  1. Any idea on what version of Ardupilot will support ExpressLRS?, and
  2. I’m new to Ardupilot, so wondering, does current Stable 4.1.0 support Crossfire (Express LRS uses Crossfire protocol but I believe there’s a difference between the two implementations)?

So I know some people have had some success, but I have not put any effort into debugging issues and I do not have any ELRS hardware. You are right that the protocols are subtly different and I believe you need some patches to OpenTX to get things working. The best person to ask is @yaapu

Thanks for your response. I switched receivers to a Crossfire Nano. Got the Crossfire Nano working.
Of note, ExpressLRS site says to use RC_OPTIONS = 9 for ExpressLRS receivers. Suppreses Crossfire Mode/Rate Message for ELRS systems?

This RC_OPTIONS = 9 does not work for me with the Crossfire receiver. Had to switch it back to RC_OPTIONS = 32. Then Crossfire receiver works.
Now I’m wondering if the ExpressLRS receivers might work with RC_OPTIONS = 32. I may try this out at sometime in the near future. For now, I’m happy with Crossfire working! :grinning:
I do have ExpressLRS working with OpenTX fine with other firmware

RC_OPTIONS = 9 is to avoid OSD spam for RF mode changes - mode changes are one area where ELRS is very different

RC works fine on ELRS 1.x, there are differences with CRSF though, I wrote a quick summary here

ELRS works for me very well on at least two different boards (PixRacer and Matek H743-mini) with Copter 4.1.0 including its assorted beta predecessors.

(I use ELRS version 1.0 with early HappyModel hardware, but that shall not generally matter.)

I wonder whether someone treats messages like “RC_OPTIONS = 9” as not setting the 9th bit to 1, which would make sense, but to actually setting RC_OPTIONS to 9 (which includes the 0th bit “Ignore RC receiver”).

I now have it working properly.
To answer your question, “Yes, absolutely” to some people (me) in the context of the paragraph on the ExpressLRS site here with the actual “values” in the preceding two statement, I was actually placing the value “9” for RC_Options.

It turns out, the default “value” of 32 does work for BetaFPV 915 MHz and Happymodel ES900 receivers. I believe what that ExpressLRS site should have stated for a “value” was 2 to the 8th power = 256 for the actual “value” to be consistent with the two previous statements in the same paragraph. (the “value” of 256 does work) OR, “toggle on the 9th option in the drop-down menu which appears in Mission Planner,” OR “enable Passthru extensions for CRSF telemetry” for the RC_OPTIONS parameter.

This all seems to be a documentation problem. I have filed a bug on GitHub, so that the maintainers specify what they actually intend to do with RC_OPTIONS.

Thank you. Yes, I agree, documentation which could lead to misunderstanding.
Thanks again!