No PWM outputs Ch8-Ch16. Advise please

Im trying to add a seagull camera controller to my pixhawk setup.
When I monitor RCin in on the various channels I want to use (like AUX1, RC9) there is the correct PWM signal but although I set RCfunction to 1 (passthrough) there is just zero out. Im getting zero out on channels 8-16.

Im sure I missed a parameter that enables this but cant figure it out (tried BRD settings also)


No ideas anyone?
The RCpassThrough works fine on channels 1-8 but not 9+ ,AUX channels.
This problem is holding me up adding more camera control features so keen for an answer.

You don’t say what is your radio system

Its a Taranis 9 but since the PWM in is working fine its not really relevant. The point is that the RCpassthrough insist passing through on channels above 8

I have the same radio and can use all the channels on the AUX pins. Do you have a log file to check parameters ?

2017-04-03 12-45-06.bin (198.9 KB)
2017-04-03 12-45-06.log (405.9 KB)

Just made a quick log today. ive tried the passthrough option on the higher channels. From the pic you can see there is a PWM value going in but just zeros out.

Do you have MAVLink 2 enabled? If you don’t, you won’t get the values for output channels above 8.

Have you actually physically tested that you don’t get any output on those channels or are you just relying on MP’s information?

How do I check or change which MAVlink is enabled please?
I initially plugged an alexmos gimbal pitch input in those outputs and it didnt work. I changed to a lower channel and it worked.
I didnt check again with a servo etc as dont have free one. Also the (tune) live graph thing shows no output.

By the way. If I only want to control gimbal pitch, is there ant advantage using a serial link instead of PWM?

Thanks for help.

Two steps:

  • enable MAVLink2 on your serial connection with the parameter SERIALx_PROTOCOL
  • enable MAVLink2 in MP by clicking the Stats button (on the upper right when connected to the autopilot) and then the MAVLink button.

Regarding gimbal, I’m not sure what you mean about serial vs PWM.

Brilliant Francisco. Thats cracked it after a week of frustration. Im surprised that none of my searches turned up an answer. There must be many others that have been stuck with this.

Regarding the gimbal.
The pitch of the Alexmos (simpleBGC) can be controlled by an RC (PWM) input but I have just seen that its also possible to control it via serial connection (from TELEM2). As I ONLY want pitch control (all other camera controls are from a seagull controller), is there any advantage to either connection. Before this fix i was running out of channels but should be ok now.

Another answer I cant seem to find - could you point me in the right direction please.–
Trying to set up gimbal pitch so the pixhawk knows the angle. There is interaction between Taranis TX, Alexmos, and pixhawk. Is there a wiki chapter explaining correct setup and calibration.
Thanks again.

Great you got it working.

Regarding the gimbal: if you use PWM passthrough there is no way for ArduPilot to control the gimbal. So if you want ArduPilot to have any kind of control (for missions for example) you will need to use a serial connection and setup the mount type to Alexmos. You’ll still able to change the pitch with your RC controller.

As a wiki page there is and might be interesting for you too.

Hi Francisco, Sorry to be a nuisance. I have followed exactly, all the info about connecting the Alexmos via serial to the pixhawk and I cant get any success. A few days ago I posted on the basecam forum for help but have had no response.
Its just like there is no connection. I post below what I put on the basecam forum. Apart from swapping the 433 telemetry onto TELEM2 port, is there any other way to test if it is working?

Hi All. Id like some help if possible.
My gimbal and pixhawk have been working fine for a year, just using PWM for tilt angle.
For better performance I decided to try the serial communication. Have now spent 3 solid days trying everything over and over. Have followed the manual exactly, tried re-wiring several times. trying to use TEMEL2 on pixhawk. Using RX wire on ROLL pin and TX on YAW pin (have also tried swapping).
Getting NO an all AHRS,GPS,and the other thing. Also when try debug with heartbeat just get OUT message.
have 2.60 and 3.0 pcb. Tried both serial channels.

Guess I cant try the UART1 TX and RX solder tabs as this will disable the USB GUI connection correct? how would I then know if it connects?

Have also checked all advice regarding pixhawk side. Confirm protocol is MAVLINK not ALEXMOS? pixhawk wiki still says use ALEXMOS.

If I join the TX and RX pins for test, should I see something happening on the debug screen?

Anyway, Im completely stuck. Im an ex computer communication engineer and have no more ideas.

Any advice much appropriated.


From your description, you are using MAVLink? If you are, you shouldn’t. I’m not sure why or when Alexmos started supporting MAVLink but we don’t have a driver for it in ArduPilot - we do have one for STorM32 but I can’t guarantee it works with Alexmos. What have you set MNT_TYPE to?

Well now im even more confused.
Does this Ardupilot link not suggest that it should connect via telemetry(2) port?
As it suggests I set MNT_TYPE to 3, Alexmos serial. However there is a discrepancy as ardupilot docs suggest setting protocol to 7 (alexmos serial) but the Alexmos manual says to set it to mavlink (1 i think).
Either way I cannot get a link, had have been through all settings, trying many things.
This video is from Alex Moskalenko himself, testing the serial link on a PX4.

Francisco, are you saying the serial link via telem2 will not work at this time?

Give me a second to kill the people that named that port TELEM2 :smile: It is just a serial port, it can output MAVLink or any other protocol. It will work fine if you set it to Alexmos (7) like our wiki says.

If the Alexmos manual says to put that to MAVLink on ArduPilot then it is wrong - we don’t have support for that (we are very open for a contribution for that). The video says it is with Copter 3.3, but as far as I know no gimbal driver was removed since then. My guess was that they are using the STorM32 MAVLink gimbal driver (MNT_TYPE set to 4), which doesn’t seem ideal - I went ahead and looked at the manual, see page 70, it says to set MNT_TYPE = 4.

In my opinion you should try both and see each one you works best for you:

  • SERIAL2_PROTOCOL to 7 and MNT_TYPE to 3 or,
  • SERIAL2_PROTOCOL to 1 and MNT_TYPE to 4

Just don’t mix the two, it’s either one or the other. Reboot after changing the pair of parameters.