No PWM output from Pixhawk

Hi, I am new to using pixhawk controllers but not new to RC devices and such stuff ( been using arduino, controllino and their variants until now)
anyways, I am having trouble outputting PWM from the pixhawk, tried the throttle pin (MAIN OUT 3) and several others (like the MAIN OUT 7 and 8) with no success.
Here is an explanation of what is my setup (currently not aiming to a rover or copter or any of that just using what I have to try and operate motors and the gps and compass and everything):
Pixhawk RadioLink (this is what’s written on the pixhawk) with gps module, safety switch and buzzer. Also rocking a Futaba Receiver connected to SBUS (RC IN on the pixhawk) and Roboclaw Brushed DC Motor driver (connected to MAIN OUT 3) . I managed to Calibrate the input from the receiver (works pretty good with 1093 to 1935 range), I also know that the Brushed DC Driver works since I used it with an arduino many times. I should mention that the pixhawk is armed aswell.
I would love some help, Thanks in advance :smiley:
Pixhawk Parameters.param (13.9 KB)

After arming the vehicle, did you see (SAFE) in Mission Planner HUD? You need to push the hardware safety switch before arming the vehicle. You might need to calibrate your driver with Pixhawk. Does it work with the receiver? Install plane firmware to the pixhawk. The first channel is the aileron so when you move the aileron stick on your transmitter in MANUAL flight mode, you should be able to move at least a servo connected to the first servo output on your pixhawk. If it works, the problem is at the DC driver.

didn’t see a SAFE message in the HUD before or after arming. no need to calibrate the driver (unless the pixhawk itself needs some kind of calibration for RCOUT) since the driver works perfectly with the receiver alone and it’s configured so it will receive 1000-2000 of duty cycle.
Changed to plane and noticed the 5v pins in the MAIN OUT and AUX OUT are not “working”. no 5v output. so no 5v or pwm output. Could it be that the pixhawk is damaged?

Pixhawk doesn’t supply power to the output rail.

That’s good to know (Although it’s pretty weird to have a line of pins doing nothing) so Thank you for the information.
Still when the PWM pin is connected and GND pin to the driver isn’'t doing anything. I should let you know that the driver has a program that can show me what PWM it’s receiving(worked with the program for a while now) and it’s showing me nothing

Since servos have widely varied voltage ratings, the servo power rail serves as a bus where you can supply your own power source.

So is there a chance that if I plug a battery to the middle servo pin, I will see a difference in the pwm?
Also, if I plug a battery to the middle row in the MAIN OUT, is there a chance to over-voltage the pixhawk?

Dont use a battery - you need to use a “BEC” (battery eliminator circuit in RC terms) or voltage regulator for the desired voltage such as 5volts, or maybe 6volts or more for some servos.
That does not affect or change the output on the PWM pins though, it only provides power to another device like an opto ESC or a servo.

For the PWM pins to provide any output the system has to be armable and the safety switch pressed.
Or set BRD_SAFETYENABLE,0 to NOT use the safety switch.
Also see BRD_SAFETY_MASK for outputs that should ignore the safety switch and will work while NOT armed.
MOT_SAFE_DISARM could come into it to.

Be aware that some of these options mean motors could operate at any time and that could be extremely unsafe.

I have a BEC so I tried plugging it in the Pixhawk, it shuts down until I unplug it (weird right?)
Also, the Pixhawk is armed and the safety switch is pressed, still on PWM output.
Could it be that my Pixhawk is damaged?
EDIT: I managed to output PWM by replacing my Pixhawk to Pixhawk 4 mini(a bit pissed off because it’s my 4th Pixhawk and each time when I simply replaced it something worked)
now I calibrated my RC input(getting 1095-1935 duty cycle which is good but not best) and am trying to give out 1000-2000 duty cycle. I ran into 2 problems.

  1. THROTTLE PWM isn’t changing, in the data tab I’m getting “SAFETY” warning although my BRD_SAFETYENABLE is set to 0 ( I also don’t have a place to plug in my safety switch in the px4 mini)
    Secondly, when I move the other pins, they move each one differently.when I move 1 (aileron) on the joystick, output 1 changes 1100-1700 and for some reason 4 (rudder) is moving with it 1300-1600. when I move 2 (elevator) it’s moving very slowly.