No Parameters are displaying on mission plannar

As mentioned, we need way more information.

  • How is your Pixhawk powered?
  • How do you connect to your Pixhawk ? (USB cable, telemetry transmitter, WIFI,…)
  • What operating system do you use on your computer ?
  • What connection settings have you used ? ( top right hand corner of MP)
    …The more information we get the higher the chance to find a quick solution.

My pixhawk is powered through USB

I connected pixhawk with USB

I used windows 10 operating system

The settings on my MP at top right

My Quadcopter view

The data at left side of MP

I don’t have Windows10 so not 100% sure, but the pixhawk should be listed differently.
What other options do you have in the drop down list?
Also the baud rate is almost certainly wrong. - usually more like 57600 or 115200

I too have mac OS, but MP doesn’t support in it ,I can install APM planner in mac OS if it is necessary .

Can suggest me how to check,that pixhawk is it in proper state or not

After giving baud rate

No change

Is “COM7-1GENERIC” the only choice in the drop down list?

Yes ,the only option I could see here

The light of pixhawk still

Which operating system do you have??

I use Linux.

Anyway, MP is connected to something as indicated by the icon on the far top right.
Click disconnect - wait until it shows disconnected icon -then click connect. The connection window should pop up. If it cannot talk to Pixhawk it will tell you after 30 seconds.
Then repeat above process but after icon shows disconnect state change baud rate and press connect again.

I had all my flight-controllers work on USB with either 57600 baud rate or 115200

→ Just noticed, you are connected just not talking for some reason. You can see this in the very top of your screen where it says " ArduCopter 4.2.2"

Found the problem: In the screenshot that you’ve sent earlier it states in red “Config Error: Fix problem then reboot”
Somehow your configuration is messed up.
…that’s why nothing else works

So ,how I can check step by step to clear the mess occurred here
Can suggest

Disconnect USB cable. Wait a few seconds then connect it again.
See what Mission Planner does at the top right regarding the connection icon and also to the left if “Arducopter 4.2.2” is showing again.
You may have to click on the config tab / icon and see if initial settings are still there.

After connecting, it is showing this .

When I clicked on config icon showing this

Is this a new setup of drone?
If so, then certainly won’t work as you need to setup and calibrate everything first before you get any correct function on the main screen of MP.

After connecting it showing this

Ahh, there you go. Never seen that screen.
But I believe this may be linked to the bootloader of your FC

Here is the answer - at least appears so:

When I clicked on critical service bulletins. It is showing this

I have installed very latest version that is 3.7.3 , I think I should install 3.6.12 version??

No, it would follow the instructions as per the link I’ve sent you as this is more recent …especially later in that post where they talk about using QGroundcontrol.

Shall I install now Q ground control .

Those instruction from Dave not working?

Also note this remark given in that link I’ve sent you:

If FMUv3 doesn’t work you might find updating the bootloader sorts it, both my clones (not MRo) were detected as FMUv2 but they had the fixed chip so with an updated bootloader work fine and are now detected as FMUv3.
Qgroundcontrol can update it and has instructions if you google update pixhawk bootloader.

→ Only proceed with QGroundcontrol if above advice doesn’t work.