No MinimOSD data until connect

Hi Folks,

Been running various 3.3 RC copter builds on Pixhawk for the past number of months.

I have a problem at the moment when I power up the quad the telemetry data on the MinimOSD is reading zero for things like voltage, number of sats, etc.

These numbers remain on zero, unless I hit connect in Mission Planner over the 3DR telemetry. The instant I hit connect the numbers on the MinimOSD start reading correctly. For the remainder of the flight everything is normal but for the next power-up I have to repeat this process once again.

It’s a telemetry Y lead connected into TELEM1 on the Pixhawk with the MinimOSD and 3DR radio at the other end. I’ve also tried with only the MinimOSD connected. Also tried hitting the fix OSD button in Mission Planner but I can’t find any solution.

Could be a configuration issue (when I went from 3.2.1 to 3.3 I did a complete reset to defaults), or something else? Any ideas appreciated.


By chance do you have both TX and RX cables connected at the minimosd ?? You really don’t need the TX cable just RX…

Sent from my SM-N920V using Tapatalk

Only the RX line is connected to MinimOSD

The problem is that by default, Copter doesn’t send data down all the serial ports unless the thing (i.e. GCS, MinimOSD, etc) asks for that data to be sent. So in this case, the MinimOSD is connected but it’s TX line is not connected so it has no way to tell Copter what data it wants and at what speed.

The solution is to either connect RX/TX lines from the minimOSD to some free telemetry port on the Pixhawk (or equivalent). Another option is to set some of the SRX_ parameters (where “X” should be replaced by a number from 0 ~ 3 depending upon which telemetry port is used) to be non-zero so that copter does, by default, send data even if it doesn’t see a request from the GCS/MinimOSD.

By the way, this issue is discussed on the MinimOSD wiki page in the trouble shooting section. … leshooting

I fought this same issue for days. This is how I finally got it working for my APM quad-

Use a Y cable to connect to both the Minim OSD and Telemetry radio. The OSD RX is from the APM TX splice, also 5v+ and Ground are spliced to corresponding output of APM. That’s it for the connection.

The issue I fought was the following:

  • Battery, voltage, time, altitude, etc. showed “zero” on my heads up display. APM was not sending data to OSD (or telemetry radio for that matter). The artificial horizon WAS WORKING.
  • Connecting APM to my ground station (Mission Planner or Droid Planner) would immediately cause the APM to begin sending data to OSD, and now my heads up display starts showing data normally. Disconnecting the ground station, the OSD continues to function normally. The problem with this is I don’t want to connect then disconnect my ground station every time I want to fly.

Here is how I got it to work without the need of connecting the ground station:

  • Set the parameter “TELEM_DELAY” to 10 (delay 10 seconds). This delays communication attempts between the APM and Telem radio. I think what was happening is that the radio was initiating communication with the APM before the APM was ready to receive the request. So the APM never started transmitting the data.

  • Set parameters per the following:

SERIAL1_BAUD, 57 (telemetry output at 57600)
SR1_EXT_STAT, 2 ( 2hz for waypoints, GPS raw, fence data, current waypoint, etc)
SR1_EXTRA1, 5 ( 5hz for attitude and simulation state)
SR1_EXTRA2, 2 ( 2hz for VFR_Hud data )
SR1_EXTRA3, 3 ( 3hz for AHRS, Hardware Status, Wind )
SR1_POSITION, 2 ( 2hz for location data )
SR1_RAW_SENS, 2 ( 2hz for raw imu sensor data )
SR1_RC_CHAN, 5 ( 5hz for radio input or radio output data )

I also tried to set SR0_xxx, but never got it to stick as others have also discovered. I understand that SR0 is for the USB, and SR1 is for the telemetry port on APM2. I don’t think it is necessary to modify SR0 anyway.

The above worked for me, hopefully it works for you if you are having the same problems. 10 seconds after plugging my chopter in, I have all OSD data reporting. By the way, I flashed my minimOSD with MinimOSD-Extra.

Good luck

1 Like

I’ve been trying to figure the issue of not getting telemetry through OSD unless I connected to the ground station for awhile now. I’m using an APM 2.8 and seen many posts about setting SR0 and SR1 for the 2 telemetry ports, but I have not seen anywhere about TELEM_DELAY. I set mine to 7 secs and that resolved the issue for me. I can see where OSD takes about 7 secs now to get the info from the APM, rather immediately showing no data.