No manual control of flaps when servo output set for flaps

Hi,
I am fairly new to Arduplane - have been using Arducopter for a few years now, but have only been flying planes for a few months. So forgive me if i am missing something simple.

Up until now I have been manually controlling the flaps via a 3 way switch on my radio. But there have been a few occasions where I have forgotten to deploy them when needed. So I want to set them up to work automatically. But I am hitting a snag before I even start.

At the moment I have my flaps on channel 6, which in turn operates the servo 6 output on my f/c. For my manual control i found i had to set the servo 6 option to ‘Rc Pass Through’. If I set the option to Flaps i have no manual control. (unlike my ailerons, elevator and rudder - each of their servo options are set to the correct function - aileron, elevator and rudder. With those i still have both manual and auto control) But not so with the flaps, the only way i can get manual control is by setting the servo 6 output to rc pass through. And of course then i cannot set up automatic flaps.

I have the RC6 Option Param set to zero - ‘Do Nothing’. I tried setting it to 46 - ‘RC Override Enable’, but that made no difference.

It’s left me a little confused. Am i missing something simple? Any ideas on how to get both manual and auto control of flaps, would be very welcome.

I am using a Taranis X9D Plus
Matek F765 Wing F/C
Arduplane 4.1.0

Thanks,
Steve.

Hi Steve,

I don’t see you mention setting up your RC channel 6 option to “Flaps” (number 208).

See https://ardupilot.org/plane/docs/parameters.html#rc6-option-rc-input-option

Hope that helps
Sam

Hi Sam,
You are correct, I had not set the RC6 option to flaps (208), it was not in the list of options given in Missions Planners full parameter section for RC6 - for some reason that list stops at 102 - camera toggle. So that page you linked to is very handy indeed. Certainly opens up some more opportunities seeing the other options.

However, it does not appear to have solved the problem. Even after changing the RC6 in option to 208, the second I change Servo 6 to either flaps, or flaps auto, i lose manual control of them.

I have noticed however, when it comes to my other flight controls, all the RC channel options for those are left as Zero - Do nothing.

They are set up like this-

Throttle is RC2, RC2 option is set to 0. Servo 2 is set for ‘Throttle’.
Elevator is RC3, RC3 option is set to 0. Servo 3 is set for ‘Elevator’.
Ailerons are RC4, RC4 option is set to 0. Servo 4 is set for ‘Ailerons’.
Rudder is RC5, RC5 option is 0. Servo 5 is set for ‘Rudder’.

All of them work as expected - i can control them with my sticks, plus the flight controller can control them. But for some reason i cannot get the same to happen for the Flaps - btw, the flaps are just split from the one output.

Am i correct in thinking i should be able to set it up so that i can have manual control plus auto control? For example, in ‘Take Off’ mode, the f/c takes control of the throttle, regardless of my throttle stick position. My aim is to have the f/c automatically lower the flaps when i switch into ‘Take Off’ mode, regardless of where my flap switch is set. I hand launch the plane, a 2m pusher glider, and without flaps, unless i am launching in to a good headwind she struggles to produce enough lift in time to prevent her hitting the ground. To make matters worse, the normal direction of the wind here comes down the field, meaning i am launching towards rising ground.

I know the simple answer is to remember to lower the flaps manually before i launch, but i still manage to forget occasionally. Hence I would like to have the f/c insure they are lowered for take off, then raise them once the take off is complete. (I cannot accidentally leave them manually lowered because i have set my radio to nag me every ten seconds that the flaps are still down - yes, i often forgot to raise them once in the air!).

To make this work, i am presuming that i need to set the servo output to either flaps, or auto flaps? Or am i wrong in that assumption? It would seem to make sense, but, if i set the servo to either of those i no longer have manual control. (despite setting RC6 to 208).

Is what i am hoping to achieve possible?, if so, i must be doing something wrong - i just cannot work out what it is!

I guess my other option would be to set up a mix on my radio, so that when my mode switch is set to auto launch, it automatically overides the flap channel. But i would like to see if i can get it to work from the f/c first.

But thanks again, Sam, your link opened my eyes to some further options that are not listed in the params list in Mission Planner, some of those may come in handy in the future.

If anyone can see what i am doing wrong, please let me know. Thanks.