No heartbeat packets received: cannot connect to pixhawk 2

Dear forum members

I am new in this place but I hope you can help me. I built an octacopter and wanted to use the new pixhawk 2 “cube” flight controller. I have the latest “mission planner” installed but there is no way to connect to the board… I always get the “no heartbeat packets received” error after the PC tries to connect with the board… I have expereince with the first pixhawk and also with a 3DR solo. I am new to the “cube” but I have “some experience” with other similar boards.

I tried everything but there is no chance to connect or to upload the firmware. The SD card is in place, The ocnnection are OK. The funny thing is that IT HAD WORKED but after some days it stopped. Could I have “fried” the board? Is there anything that I can try?

In the video you can hear the startup sounds. Is it everything normal? I did not find many info on the internet regarding the new pixhawk :frowning:

You seem to have the ‘motor arm’ tone straight after boot.

Could you be stuck in an ESC calibration mode? Try disconnecting your receiver and seeing if the startup tones differ.

Thanks @_Matt.

I tried disconnecting the receiver but nothing has changed…
On the other hand side, it could be that the Pixhawk is somehow stuck in the ESC calibration procedure… I do not remember exactly where but I was in the set up screen when suddenly the pc refused to connect…
Is there any way toi “reset” the cube and start from scratch?


1 Like

Try booting whilst you hold the safety switch down. That may force it into a mode to allow you to re-flash the firmware. If not, the PH2 group on FB is very active with both users and the developers/designers/manufacturers. Try asking over there.


Hi @_Matt

The Pixhawk does not have a safety switch (not with the here GPS at least…)
I placed the same “help request” in the Facebook group but no major ideas are coming… :frowning:

The safety switch is on the here GPS. It’s the button at the centre of the circular LED.

1 Like

Total frustration. New to Pixhawk 2. Using a Mac Laptop with the latest OS and using Windows 7 in the software Parallel. Used Mission Planner in Windows, latest version. I was able to connect (via Auto) and did all of the configuration till I got to the ESC Calibration. Followed the instructions to disconnect and I have never been able to connect again. I have tried reinstalling software, unplugging and plugging in components, installed Device software, even bought a new flash drive card and reinstalled firmware. I still get the same message that there is no Mavlink device? I am at a loss as to what to do.


Virtualisation just adds another layer of potential issues. For debugging purposes, try something native to Mac like APM Planner:

Try connecting to see if it works. If not, disconnect and reconnect the USB cable but don’t press the connect button. Click on ‘Initial Setup’ and then ‘Install Firmware’.

Now choose a different setup than you plan to use. If you’re using it on a 'Copter, install plane or vice versa. This will completely erase the firmware and all settings. Once complete, follow the same steps to install the correct firmware to the device.

1 Like

Thanks very much for the response and your suggestions. I will work on it this morning.



Hi _Matt

Thanks for the suggestion. That helped me coming back to a normal situation… now I have other issues but at least I made a step back. I did not know that the safety swithc was the one on top of the GPS… Maybe I missed something in the instructions…

thanks this was the case with mine this evening and fixed the issue