No GPS in 3.4rc2

I upgraded to Copter3.4 rc2 on my official Pixracer (no clone) but now my Ublox Neo-M8N is no longer working. It works on the Ublox app and shows a full 3D lock. I have checked the wiring and I seem to have signals on both the Rx and Tx pins, I changed the GPS-Type from Auto to UBlox but that made no difference. The LED on the GPS flashes briefly off every 1sec.

Any suggestions, please?

regards Peter

Sorry no suggestions just a +1 on this, thought it was just my setup.

Does it work in other versions? A log would be appreciated.

I have tried 3.4 and 3.4rc1 loaded both from QT and from MP and also tried a different GPS. Still the same. I think my Pixracer board must have died.

Does the GPS get put into a different mode (ie not NMEA) on start up or does it use the standard NMEA output?

Which log would help to diagnose the problem?

regards Peter

I also tried PX4 loaded from QT but that did not detect a GPS either.


I seem to have had a win with this.

On answering someones question about strange behaviour of their quad and advising that a an erase and reload usually fixed it for me, I realised I had not tried this with the PixRacer board.

So I loaded release version of Plane.
GPS was identified (No Fix message as I am in the office)

Loaded release 3.3.3 of Copter and got a No Fix again, GPS identified apparently.

Loaded beta release 3.4-rc2 and got a No Fix again, GPS apparently identified.
Currently waiting to see if I get a GPS fix.

Will report back

I would like to try a complete erase of program and data memory before reloading as I suspect this could be the cause of my problem. I note that when loading a new version of the software it says erasing but it appears that it is not erasing everything.

Since the CLI disappeared in an earlier release of APM I have not come across any method of being able to test sensors etc. do a full erase etc. How can I do a complete erase?


By loading a different airframe’s firmware.
That’s why I loaded Plane, which forces a complete erase, then loaded copter, another erase.

This seems to indicate that the problem is in the hardware and not in the software.

The dataflash log would help (although the tlog should be enough):

To reset the parameters there are multiple ways:

Have you compared the GPS cable pin out to the GPS connector?