No Flight mode in Drop Down

Flight modes seem to be missing in 1.3.28 … I go to go to "Initial Set up> MAndatory Hardware>Flight modes>"Try to set up my flight modes in Mission Planner but there is NO modes in the drop down
I have uninstalled and reinstall MP with no luck.
Any help would be great

please goto the help button, then run an update

this will hopefully regenerate the param list

I did try the update first with no luck
did a reinstall same thing
then is doing a beta update. ( solved the issue


I have the same the situation with MP 1.3.28 no flight mode in drop down menu.
I have tried both normal and beta update, but no luck.
Please help.
I use APM 2.0 with arducopter 3.2.1. My MP is in Windows XP.

I had exactly this same issue a few nights ago. Also there were no values in the failsafe drop down on that page. I restarted MP several times and eventually the dropdowns started working properly again. Very strange issue. I checked other dropdowns at the time of the issue and all seemed OK aside from flight mode and failsafe.

Same here + opt 6 7 8 and all the params descriptions

please do another update to the latest beta if that’s what you are running.

the problem has now been fixed


I just updated Mission Planner. New beta revision is available. Not sure if it fixes the drop down issue. It was a temporary problem in my case (fixed itself after several restarts of mp.

Sent from my Kindle Fire HDX using Tapatalk

In my case, not only the flight mode was problem, all the parameters did not show. Update to beta version no work.
Just realized that it was caused by the fact that github stop support for Windows XP.
I run my MP in XP, and the update always failed on parameters.pde updating process until I modified the location config in my MP config file. Now, all the parameters work including flight mode setting.

I just installed the latest MP (not beta) latest night and experienced this problem. Update didn’t work either. However I noticed the comment here about github and XP. I am running XP. What do I need to do to fix this?


I’m having the same issue and can’t updat MP on xp? Please help?

xp is no longer supported.

Can you help please I’ve downloaded amp to mac but it only gives me the option in the drop down to connect via Bluetooth I need to connect via USB/mavlink. Thanks.