Servers by jDrones

"No Firmware for this Board" trying to firmware update PH1 and PH2.1

(Mike Boland) #1

MP on the Win7 machine on the workshop bench has worked well for quite some time.
No issues.
Updated to the latest beta a couple of days ago and now I cannot update any firmware.

After the message “Are you sure …” I immediately get a message box saying “No Firmware for this Board” and this is happening on PH1 and PH2.1

Just checked on the old laptop running Win7, worked fine with the .66 software installed, updated to MP Beta, and now it is broken as well.
Same “No Firmware for this Board” message without even looking on the comm ports.

So something in the update screwed up comms on the Win7 machine on both machines.
Does anyone know what might be the issue?
Or even where I could start looking for what screwed up in MP or Win7?

(David ) #2

Just try reinstall MP, sometimes can happen that during the update something got wrong.
If the problem continue better reinstall win7

(Mike Boland) #3

First thing I did was to uninstall MP and do a fresh download and install.
Once this error has set in it keeps doing it, even on a fresh non beta install.

Why oh why? :face_with_symbols_over_mouth:

And the question remains, why did the beta update kill MP’s firmware update capability?
And is it going to happen again even on a fresh machine?

@Michael_Oborne did the last beta update do anything to the comm ports?
The only thing I noticed was that instead of comm72 being the next comm port they were all wiped and I was back at comm9.

(Michael Oborne) #4

do you get a separate popup box when selecting the firmware?

(Mike Boland) #5

Not sure what you mean by ‘selecting the firmware’

In the Firmware screen it comes up with the current stable version under the icons as it always has.

Selecting a type of airframe brings up the usual confirmation request.

The instant the OK button is pressed I get this dialog


“No firmware available for this board”

Clicking ‘OK’ brings up another dialog

I initially was trying to load a previous firmware, following the usual procedure:




The firmware page is now broken and will not even attempt to look at a comm port.

The normal ‘connect’ works, and parameters are loaded, and can be written and worked with.
I hope this is enough info.

(Michael Oborne) #6

please try the beta i released today.

im chasing the windows 7 bug atm

(Mike Boland) #7

Thanks @Michael_Oborne

Opened PM and the Beta update dialog opened.

Went to Help and clicked on check Beta and it did the update.

When PM had re-opened I tried the Firmware page and it is the same ‘not for this board’ message.

Restarted PM, restarted the computer just be sure.
Same no firmware message.

PM can still connect to the PH and load and save parameters.

(Mike Boland) #8

Went through and removed MP but also removed all the com port drivers.

Did a fresh download and install.

All now works.
So something in that beta update must have screwed the one or more drivers.