No drone location available ?!?

Hi! I just startet out with pixhawk and am trying to get tower to work on my tablet but I´m not getting any coordinates transmitted.

I know i have a GPS fix because tower correctly indicates the fix with about 10 sats and HDOP around 1.2 . But the Lat/Long widget stays empty. Touching the arrow icon on the left i get the error “No drone location available”.

I´m running APM:copter v3.3.3. on the pixhawk and connect via 915mhz radio link on an OTG micro usb adapter.

Am I missing something or is this a bug?

EDIT: Never mind, problem solved (more or less). Had a chance to fly outside today and everything worked. I assume that tower only shows you gps coordinates and a home icon if the fix is very very good. I´m not shure what the threshold is, but I had a HDOP < 0.7

What happens when you arm the quad? It should update the location and set the home location. I know sometimes for me it will only show the location once I arm.


When I arm it, the app does say waypoints received, but I still dont get a location, home icon or Lat/Long.

Well I don’t know it most likely is a bug. I know for mine it takes sometime to update the location. It’s telly a hit or miss thing with mine.

@mapmart Can you provide the tlog file from your vehicle.

The same thing happened to mine too.
No update home location and no rssi for the tellemetry…

I think it s a problem for sr perametrs

I have seen this too. If the GPS lock is not good enough a home location is not set so this message is shown. After arming and flying for a while it did get a good GPS lock and home was set at that point in the air. The home location then shows up in Tower.


At mine either at tower or mission planner never got a home location