No COM port after ChibiOS install on Matek F405-STD

Hey guys, I just successfully flashed my Matek F405-STD board through Betaflight with latest stable Arducopter hex. After that, none of my Windows 10 machines identify it with proper COM port. The com ports are there but they are hidden. The drivers even show as “HEX” as if it was a Pixhawk. The device also shows up under USB devices.

Is this a common issue?

Looks like you did not used the proper binary
Just checked on my computer I it shows as a matek

Here is what is loaded
Frame: QUAD
MatekF405 001D0023 3037470D 31373434
ChibiOS: 57801550
ArduCopter V3.7.0-dev (ce935294)

I have the same problem.
(For the record, I am 100% sure I flashed the version with BL…)

How can I proceed from this point?

Had the same issue and turned out to be the different Windoze drivers needed for Chibios.

Just re-install Mission Planner as the drivers have been included with the new install.
I had to remove my old version first to make sure it did a complete install.

Matek provides a driver on their webpage which works for connecting to the FC.

I had to do the FW update the following way:

  • Press BL button on startup.

  • Install Zadig driver.

  • Flash with Betaflight Config in DFU mode.

  • I flashed 3.6.5 with boot loader and I am still not able to flash through MP directly after that.
    (- Mission Planner will not recognize the FC in DFU Mode)
    (- When booting normally, this message appears: Latest Beta Build will not load firmware , recommended fix wont work.)

Mission Planner 1.3.62


  • I re-installed Mission Planner, it didn’t help.
  • I flashed FC with beta firmware instead of stable, always choosing “with_bl”, it didn’t help.

This is what my ports look like. I’m not sure what the COM1 is, it doesn’t seem to go away even if I remove my bluetooth modules on this PC. It looks like an old device, but anyways the Matek surely isn’t showing up. Mission planner still does not recognize the device either.


Did you completely de-install Mission Planner first?
I found if you didn’t de-install the re-install didn’t put the newer drivers in.

Your PC sees the board but the drivers aren’t loaded
When you plug the board in does windoze try to install the drivers and say it cant find them?

A few weeks back I think I messed up my Windows drivers on two machines trying to troubleshoot a Mavlink telemetry radio. This is what worked on one of my machines after fiddling everything for more than 8 hours…

*I tried using MatekF405-STD firmwares that I saw under “latest” firmware tab. I’m not sure if there’s a difference between those and the ones that don’t have “-STD”.

(1) Go to Device Manager on Windows and uninstall all hidden and not hidden devices
(2) Install STM32 VCP drivers
(3) Re-start computer
(4) Right click on MatekF405-STD USB device and use STM32 VCP drivers
(5) Uninstall and re-install Mission Planner
(6) Connect Mission Planner on the VCP port (mine was COM 5)

OK, I just encountered this on a fresh Win7 machine, new clean install of Mission Planner from the MSI.
Was already talking to a 6.something beta running on a Cube.
Did the update to the new stable 3.6.5 Chibios and windoze could not find the driver ?? and from then on would not even look for it.
Had the same USB entry you have (but for a Cube)
windoze won’t find it online so I went into device manager and manually searched for driver, show all device drivers, selected 3DR, then the Profi Cube driver and all worked as expected.
Seems to be a problem with windoze not locating the driver rather than the driver not being there.

Hi! Fixed same issue by changing widows driver for device manually to STM23 Virtual Com Port

Yep, this does the trick! I forgot to come back and post about this.