No CAM messages logged from Canon and Seagull SYNC2

Hi I am trying to write cam messages into the log but I still get info that there is no any cam messages when I try to georeference photos in MissionPlanner. I have copter with cube black and firmware 3.5.7. I connected camera by Seagull SYNC2 hotshoe to AUX 3 port. I set:
LOG_DISARMED - 1
CAM_FEEDBACK_PIN - 52
CAM_FEEDBACK_POL - 0
BRD_PWM_COUNT - 2
LOG_BITMASK - 176126
I don’t have any other connection from camera to cube. I just release the shutter by finger few times. There is no any information about this in the log :frowning: I am testing everything on the ground. Just arming the copter and waiting for satelites.

Did you try to set CAM_FEEDBAC_POL to 1?

Yes I tried it didn’t help :frowning:

Hmm. Set BRD_PWM_COUNT to at least 3 if you are using AUX3. It should work then. If it does not, try changing CAM_FEEDBACK_POL to 1 again.

EDIT:
Or plug hotshoe to AUX2 and set CAM_FEEDBACK_PIN to 51.

It started to work When I changed the camera form Canon to Sony. I will investigate what was the problem camera or seagull sync 2…

My seagulll sync 2 doesn’t work with Canon cameras. I get 41 cam messages, I should get 3. With sony camera everything is ok.

I have another problem. I get “AMSL Alt NOT found” during geotagging in MissionPlanner. I found such ticket but it looks like it’s still open so it wasn’t repaired ??? Any one one knows the details ?


It looks like the problem is mentioned here also: