Servers by jDrones

No calibration on APM 2.6 running Plane 3.4

Just starting out with ardupilot and I’ve reached what is a dead end for me. I’m posting hoping to get some direction in getting this fixed.

I have two ardupilots, both version 2.6, and both exhibit the same behavior. I’ve flashed Plane, both 3.4 bata and 3.4 stable, on both units and tried everything I can think of hoping for a sign. I’m running APM Planner on both linux and Apple, and the behavior is the same. I don’t think it’s the software, and I don’t think both units are defective.

I cannot get either unit under any circumstance to calibrate the accelerometers. I just get timeouts and CMD: 241 errors.

I know this problem has been discussed, but no one has actually posted a fix, and I know there is supposed to have been a fix found (issue #902) , but It seems not to have been implemented in the beta code.

In the logs, I’m getting:

STATUS TEXT: 3 : “Calibration FAILED\r”
[20180123 7:36:51.747 DEBUG] - APM: Text Message rx’d “Calibration FAILED\r”
[20180123 7:36:51.748 DEBUG] - Severity: 3 text: “Calibration FAILED\r”
[20180123 7:36:51.750 DEBUG] - APM: Text Message rx’d “FAILURE: Failed CMD: 241”
[20180123 7:36:51.750 DEBUG] - Severity: 0 text: “FAILURE: Failed CMD: 241”
[20180123 7:36:51.751 DEBUG] - handleWaypointCount() - Rejecting message, check mismatch: current_state: 0 == 3 , system id 0 == 1 , comp id 1 == 1

APM Planner times out and I never get a request to position my APM. My original unit was originally flashed with a much earlier version of ArduPlane, probably 2.7 and it did go through the calibration.

I’m looking at loading the 3.4 source and patching the fix, but that’s a dawning task from here and probably won’t work. Thought I’d post and see if anyone has the magic incantation that might make these board calibrate…

I’m thinking the best route may be to dig up a copy of the latest 2.x arduplane that worked and just go with that. It seems that 3.4 is broken for the ardupilot and I don’t see that anyone is interested in fixing it. I do have a pixhawk, but if I can get these working, I sure could have some fun with them.

Any comments or assistance would be much appreciated.

Thank you for your time.

Tom Redfern.
thos --at-- fonebone.net

Servers by jDrones