No BMM150 on i2c


Arducopter 4.3.3 currently. The bmm150 on i2c is not working. On pix32 it recognized right away.
Here are my parameters. Tried latest fw also, did not do any difference.
I think there is something missing in the firmware. (5.5 KB)

Do you mean an external compass?
Is this BMM150 part of a GNSS unit or something?

The Pix32 is derived from the FMUv5 specification
The Cube Orange isnt derived from the FMU or any previous specification according to the hwdef file
But there’s nothing in either that says i2c BMM150’s should be included or excluded as far as I can tell.

Check and change COMPASS_TYPEMASK,0
It’s a bitmask, so you can use the pop-up in MissionPlanner full parameters to add BMM150

or calculate and type in a value

I have tried the bitmask. It should be enabled. I will try and calculate it.

Ps! It is a stand alone unit with only i2c.

No difference with the bitmask, I tried enabling and disabling it. The cube does not recognize it. I have tried different cubes and different versions. None seem to work.

On other autopilots that I have it is automatically is detected

Can you try the other I2C bus which is on GPS1? I have a BMM150 on that I2C working with me here.

Its weird that it works there, but not in any other serial port.

I think It’s just bus number mismatch.