Servers by jDrones

No bars visible in Mission Planner's Radio Control Calibration


(Konrad Paul Weiß) #1

Dear Ardupilot community,
I am trying to calibrate my radio in Mission Planner.
I am following through this description for that.
However there are no green bars visible at any time when I try to calbrate.
Also I get the message “Bad Channel 1 input” after having moved all sticks around and clicking on done.
I am using a Taranis X9D+ with R-XSR that are bound together.
The R-XSR is connected to the PixHawk via the Craft and Theory Telemetry Cable.
My channels are as follows: Ch1=Throttle, Ch2=Aileron, Ch3=Elevator, Ch4=Rudder.
This is on the Taranis and in Mission Planner (RCMAP).

Am I missing something out here that I have to look for, I don’t get why it doesn’t work.


(David ) #2

Good day, im having the same rc and reciever, on my x9d plus I’ve done the following settings: on mixer page : ch1 ail, ch2 ele, ch3 thr, ch 4 rud, ch5 for the flight modes
I’ve connected the sbus of the receiver on the rcin pins of the pixhawk.
Don’t forget to bind the receiver


(Konrad Paul Weiß) #3

I found the problem.
I bought a telemetry cable with adapter from Craft and Theory to make sure everything would work fine.
However the cable connecting the RCIN signal port on the PixHawk was not connected to the SBUS_OUT port on the R-XSR but rather to the SBUS_IN port on it.
Therefore no communication happened between the R-XSR and the PixHawk.
R-XSRConnectionToPixHawk