No Autotune in 3.5rc6

Just out doing some autotuning as I just swapped out a couple of old Pixhawks for 2.1 versions. Autotune on the 15" quad worked as usual. But when doing the AT on the 960 Hex, nothing. Switch out and back in and you get a single twitch. Not moving the sticks and in PosHold mode. Autotune is on a separate switch as well. I went back up to duplicate the issue with a shorter flight so the bin file wouldn’t be so large.2017-05-18 14-20-44.bin (2.0 MB)

Remember to switch into the AutoTune flight mode (accessible either using a flight mode switch or the auxiliary switch) from AltHold or Loiter.
Also the most common problem that exhibits the symptoms you’re seeing is that the sticks are not perfectly centered. In this case it thinks the pilot is trying to override the position and so it won’t start twitching. This can normally be resolved by re-doing the transmitter radio calibration. Another alternative is to increase the size of the RC deadzone (i.e. increase RC1_DZ, RC2_DZ, RC3_DZ, RC4_DZ to 50)

I’ll be updating the autotune wiki page in the near future and I’ll add a “common problems” section that includes this additional advice. AC3.6 will include better feedback to the pilot on the state of the autotune.

I re calibrated the radio. But that didn’t help. Trims are centered as well. So I thought the options for AT were alt hold (what I’ve always used) or position hold. So use loiter instead of pos hold? I’ll increase my dead zone and to if that will kick it into AT. Thanks!

1 Like

Dead zone to 50 worked, thanks!

Great. We will be increasing the deadzone default to 20 for the next release candidate. They were “30” in AC3.4.6, we had reduced them to “10” for AC3.5 but will go for some middle ground of “20”.