No 3D fix - Here3 GPS with CubeOrange in Mission Planner

Hello all,

I am trying to use the Here3 GPS and HEX Cube Orange with Ardupilot (Copter 4.3.1 Official) firmware for my drone but so far I am not getting any signals or 3d Fix from the GPS. I have been using Mission Planner (V1.3.79) as the ground station software. It would be great if I could get assistance in solving the GPS 3D fix issue.

Below are some of the steps I tried until now to get the 3D fix.

  • modified the parameters in Mission Planner (as instructed in the official website)
  • updated Mission Planner and the Here3 GPS (as instructed in the official website)
  • changed the CAN node ID
  • tried to connect to u-center (doesn’t show any satellites though)
  • checked in both inside my house (closed space) and outside (open space)

Please let me know any additional information I need to provide too.

What LEDs is the Here3 showing?
Have you got
Maybe set LOG_DISARMED,1 and get us a .bin log file to check
then set LOG_DISARMED,0

1 Like

Hi Shawn,
Thanks for your response.

  1. The LED in my Here3 shows flashing green colour.
  2. Yes, the BRD_BOOT_DELAY is already set to 5000
  3. I am not able to directly attach the log files here. So, please find my log files in this link -

The LED indicates the GPS unit itself is working

That log has a lot of
“EKF3 waiting for GPS config data”
and no GPS in the logging.
It’s like the GPS CAN connector is plugged into the wrong port, or wiring is wrong.
Have you got a photo?

Set both GPS_GNSS_MODE and GPS_GNSS_MODE2 to only use two constellations, usually GPS and one other. Also select SBAS if you are in USA

I have just connected the GPS to the Cube Orange controller and connected it to my computer via USB.
The GPS light in the images seems yellow but actually is green.

I tried setting the GNSS_MODE as you mentioned, but still cant see any GPS signals.

Is it outside with a good view of the sky?
Even near a wall on one side is not good.

Try the other CAN port too

I tested the same connection outside with full view of sky. But still shows No Fix. Tried both CAN ports.

Although, I reset all the CAN parameters to default and now itseems Mission Planner can recognize the GPS but shows No fix as can be seen in the image below.

Now, when I restart the GPS, I can also see messages such as ‘6 raw flags = 16842753 sz 36’ at the bottom of the DroneCAN screen. Attached image for your reference.