Nexus 7 2012 File structure

Im hoping someone can help me:
Im about to leave to do some drone-based mapping abroad. I have been using a netbook for mission planner previously. I got, at the last minute, a 2012 nexus 7 to try to have a simpler field device. I had tried droidplanner on my old tf101 and had no problem setting up prefetched maps. I just dropped cached maps from MP into the location listed in the droidplanner guide and it worked.

So the nexus 7 just arrived and droidplanner installed with no problem and seems to run fine, BUT it has a different file structure and I cant get the prefetched maps to show up:

The folder sdcard/droidplanner/ doesnt exist.

I tried creating a folder called “DroidPlanner/Maps” in the “emulated/0/” folder which I think is supposed to be like the SD card location but the app shows no maps when offline maps is turned on.

It is not allowed to create a folder called sdcard in the root directory.

Any help would be GREATLY appreciated.


Wait, in settings in droidplanner it says the storage folder is


But it still doesnt seem to find my cached maps if I put them there.

and nevermind. Forcequitting and restarted the app got it. So now I have prefetched maps working and ready to go for my trip. Awesome.

@achiii I`m sorry for the delay, it looks like I acidentaly unsubscribed the forum :frowning:.

Im happy that you found the solution. The Nexus, although a great device in most aspects, has a strange way to handle its internal storage. Sometimes you need to reboot the system so it shows all folders when connected to a PC.