Newly built quad, issues with trims

I recently built my first quad with the below hardware:

Quanum Venture frame kit
APM 2.5 FC
Afro 20A ESC’s
MultiStar 350 to 450 Frame Size 2212 Combo Set With Self-Tightening Propellers
FrSky D8R-XP Receiver
9XR-Pro radio with FrSky DJT module

My pitch and roll trims on my radio are not enough to give me a clean take-off. I have to max out the trim, and then give the knob a push in the opposite direction of where it is leaning to get a lift off. Is there anywhere in mission planner that I can compensate for this?

Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Put all your trims to center and do Auto Trim

When I attempt to get logs, I get what appears to be binary data in the console. Is this a bug?

[code]Init ArduCopter V3.2.1 (36b405fb)

Free RAM: 1999
FW Ver: 120

load_all took 17980us
?3 ?Calibrating barometer ?? Q??? Q? ?3?barometer calibration complete o??3?GROUND START t?Init Gyro*? Q.P*
Ready to FLY ublox ? Q_? a Q?![/code]

Today I reset everything to default and I have the same issue, except now it leans to the right instead of the left.

Here’s a video I took last week prior to resetting everything where it leans to the left, sorry it is small. … umFail.mpg

Here are the logs from 3 attempts to lift off of the ground where only one side of the quad actually lifts. Please let me know if anything additional is needed and thank you for your time.

Hoping these are the correct files. I deleted all logs off of the board and in my logs folder, went and did a few lift off attempts, connected board to PC and downloaded the single log item that was available.

Here’s more if it helps. I was trying to auto tune but I was only able to get it off of the ground for a few seconds and I had hardly any control over where it went. I have to have my radio trims maxed out to the down and right respectively for my right stick (mode 2 setup) and its still nearly impossible to get up. I confirmed all of my motors are spinning the correct way and the props are in the correct locations.

I noticed that after calibrating my accelerometer my quad appears totally level in the flight data screen. After I attempt to lift off using the auto-tune (holding throttle down/right for 15 secs) and trying to hold it level to calibrate, when I connect my quad to mission planner again, I appear tilted (roll) in flight data and it is no longer level. Is this one of the items calibrated in the auto tune?

Can someone please give me some ideas for what I can try, this is getting really frustrating. Been trying to get my quad off of the ground for over a month.

I think my issue is partially solved. I deleted the profile for the quad in my radio (9XR Pro) and created a new one. The profile I was using came already built into the radio and I’m not thinking the settings were bad for my quad (if thats possible).

I can now get the quad off of the ground, but I have to always give it a bit of right tilt to get it to lift off level–and I need to maintain holding right tilt to get it to balance in the air. It wants to bank left on lift-off. I tried doing the auto calibration multiple times but it is not fixing the issue. Can anyone recommend something for me to try?

My issue is solved.

I think the problem stems from using the default/built-in profile on my 9XR-Pro radio. Initially I had an issue where my radio was working as a Mode 1 when it is a Mode 2 radio even after adjusting channel order. I had to adjust the RCMAP_ settings in Mission Planner to fix this. Secondly, something was causing an issue with trims causing the quad to lean on liftoff which is why I created this thread.

I deleted the default profile in the radio and created a fresh one–100% clean slate. This solved my mode1/mode2 issue as noted above, but I was still having a roll issue but then read the below troubleshooting page. It turned out that my roll trim was in the ballpark of 1900 instead of 1500 which was probably making the FC compensate for it. I recalibrated the radio and now all is well. … leshooting

I had a similar issue with my first quad. Make sure you pick the ACRO profile and not "Hellicopter"
Acro gives you a clean profile.
Hellicopter come with pre installed offsets needed to fly a helli, like linking thrust with yaw to keep a helicopter steady when thrust is applied. These offsets cripple a quadcopter.

Thanks for the feedback. I determined my issue was my roll trim APM config was close to 800 when it should be around 500–this was making it lean towards one direction instead of being balanced. I’m not sure how it got this way, but being a noob I didn’t think to check this.