Newbie lots of problems with arducopter please help

hi I still have not properly flown my copter properly. I have hk pilot 2.7 3.2.13 firmware I believe lea-6h gps power module telemetry radio not using Osd. Turnigy Tgy-i6transmitter and 6 channel rec mode 2.

  1. When setting up with the wizard the remote shows all the right directions inside the setup wizard, when both sticks are pushed up the green bars go up and left goes left on the green bars as well. So I would say the remote is set up correctly with all channels set to normal on the remote control.

Yet when I attach the power lead on my copter having the throttle stick low as you should do puts my Escs in programming mode? So I thought why don’t I just start the remote low as you have to and then push the throttle high this should then just give me the three esc beeps and ready to go. This sometimes works but sometimes I get programming mode? Any advice on this. I have done full cal in mission planner. Is there something wrong in my remote settings? If I chose reverse channel 3 in the remote settings then yes I get the copter on and it gives three beeps but in mission planner then the green bar goes down when I push the stick up and vice verser so this isn’t right then is it?

  1. After connecting power to my copter and when it doesn’t enter cal esc mode and is theoretically ready for arming. My mission planner shows in red battery A V 0.0. no gps in red. The telemetry is connected but I can’t arm and I have even disabled all preflight checks in the standard parameters, I don’t understand what’s happening?

On the whole I have had a very poor customer support from hobbyking with this and I am starting to wish I hadn’t started this project please can you help.

Well it sounds like the Throttle is at full. This would stop you from arming the unit.

Can you go into Mission Planner under Config/Tuning after connecting to your Flight Controller and go to Full Parameter List and save a copy of them.

Then upload that and we can see what is configured.


Hi mike thanks for the reply, I have gone right through all of the setup again. I downgraded firmware to 3.2 and setup the latest version of mission planner.

I have had trouble with these ESC’s because they don’t beep in sync with each other. They have to be programmed by beeps only no programming card exists. This has caused a lot of confusion and upon just going along with what you should do and just start up with throttle at minimum it does a lot of beeps and I thought it was programming mode noises being emitted. This was not the case once I turned on with throttle low and waited for all the beeps to finish then it armed ok. I also managed to re calibrate all the other settings in mission planner and the voltage gps problem I had seems to have disappeared now, I did notice that the settings in the mission planner were getting lost for the power module but they seem to be stable, think I may have solved things now. Going to try a flight later today. I still may get turnigy plush ESC’s instead as I think they would improve things somewhat.

Will post later if I have a successful flight today. Thanks to all who have looked at my post thanks for your reply Mike.