Servers by jDrones

Newbie ground testing gone wrong!

Hi, I have just had the fright of my life and my drone appears to have decided to have a mind of its own.

I have my drone indoors taped down to a large heavy box so I can do some ground testing of the propellers spinning. I turn it on, press the arm button, set it to mode 1 (stabilize). After some twiddling of the throttle up and down, all seems well.

That is until about 15 seconds in and I put the throttle down but the thing keeps going crazy and throttles up to what seems like full throttle. I tried to do disarm with the transmitter but nothing happens. Putting the throttle down did nothing. I had to crawl under my box and physically disconnect the power cable.

What did I do wrong and why does my quad want to kill me? :’-(

For anyone to be able to analyse what is happening you need to post a .bin file from the flight controller.

Have a look in the Wiki for downloading flight logs.

First mistake…indoors with the props on…

Okay, I just can’t believe there isn’t a way to instantly terminate the flight. Terminate is an option for the failsafes. Why not the flight modes?

There is
Option 31 - Motor Emergency Stop

https://ardupilot.org/copter/docs/parameters.html#rc11-option-rc-input-option

or

Option 32 - Motor Interlock

or

Option 41 - Arm/Disarm

Genius. Thank you! :smiley:

A follow up question: I would like to set my SH switch to activate emergency motor stop so I have set RC6_OPTION to this in Mission Planner.

In OpenTX Companion I have switch SH set up as in the image below, yet Ardupilot does not react (yes I do get the “engine off” sound played) when I flick the switch:

Any ideas where I am going wrong? Thanks

I’m not sure using the momentary SH switch is the best choice but if that’s what you want I would do it this way. But, there is usually more than 1 way to accomplish something in OpenTx.

Thanks, I now consider this fixed!

My “problem” was that the emergency motor stop only appears to show an effect in the debug output when you actually have the motors running. I was expecting some sort of notification when I just had USB attached and no ESCs armed.

BTW this is only for ground testing. i.e. checking for vibrations and generally getting my quad at least some way down the “bathtub curve” before I do a first flight. :slight_smile:

I’m sorry, but you won’t be able to get good readings of vibrations with the drone on the ground.

I just want to make sure the ESCs don’t explode and that the propellers don’t break when going at full throttle.

Please remember that if you use Emergency stop you MUST have that position enabled for a couple of seconds before releasing the switch, as there is a timeout of the function to allow for unwanted actions. So the switch must be enabled for 5? seconds at least. I use it on the momentary switch of the Taranis, and have a timeout counting. After the timeout expires there is no way to switch on the motors.
Emergency stop has saved a lot of expenses :slight_smile: https://youtu.be/-yJSuC2rcbw but you have to use it right and know its limitations :slight_smile:

1 Like

Thanks, I didn’t know it had to be held down. Maybe I just didn’t notice that in my testing. I think it is only 1 second TBH. I am not able to test right now though.
I have it set to a momentary switch like you. Shame it isn’t instantaneous as usually that is the point of an emergency stop - it is an emergency!!!

Maybe I wasn’t clear.
It is instantaneous, to stop the motors, but it gives you a few seconds to change your mind and get the motors back on.

Ah that makes more sense. That said, I have noticed that I have to keep the momentary switch on for a fraction of a second for it to operate. If I just click it, nothing happens.

Servers by jDrones